Acura MDX SUV Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
443 Posts
Discussion Starter #1
OK, here is what you need to do to replace your VTM-4 temperature sensor, which makes itself visible and in the center of attention if YOUR VTM-4 LIGHT COMES ON (not Check Engine light, this is important) INTERMITTENTLY AND SHUTS OFF YOUR 4 WHEEL DRIVE (REAR DRIVE). Also, this throws a code 43 which you can check using a special procedure (search this forum to get it, it's pretty cool).

I am not used to noting all the stuff as I go on, so this will be mostly a pictorial DIY, if you have questions, PM me or something.

Anyhow, the temp sensor if located at the rear of the VTM-4 unit, and it is protected by a piece of metal held by three 10mm bolts to the VTM-4 unit. Space is quite tight so be creative. Once you get the metal protector piece moved to the side (no need to undo the cable that sits in it!), you will need to disconnect the plug from the sensor. I was unable to do this without braking the tiny holding clip on the temp sensor, which was not a problem since I was putting a new sensor in. Finally, you will need a deep socket to remove the temp sensor itself AND there is so little space in there, I did not manage to put a rachet on the socket! I was stuck at this step for a long time. I had to use some trick to unscrew the sensor. Again - be creative, it is really tight in there.

Once you have it loosened, follow the normal VTM-4 fluid replacement procedure. Uncrew the fill plug (top one), then bottom drain plug, then the sensor itself.

Use the backwards procedure to assemble everything in. Use fluid pump to put new fluid in, it takes almost a gallon.

Good luck!




.




.




.




.




.




.




.
 

·
Registered
Joined
·
10,572 Posts
I am really glad you got it fixed. :D I know you had alot of trouble pinpointing the problem. Thanks for posting the pics. This DIY is going in the FAQ section.
 

·
Registered
Joined
·
443 Posts
Discussion Starter #4
Yup, me too... I have my 4WD back and I now know I couldn't live without it in this climate (already total snowfall this winter about 150cm!).
 

·
Registered
Joined
·
2 Posts
Is this the only reason that the VTM-4 light will intermittantly go off and on and you lose your 4WD? My husband is a mechanic and is semi convinced its electrical and then I found this post and I am more likely to believe those who know these vehicles...sorry hubby! Thanks!
 

·
Registered
Joined
·
443 Posts
Discussion Starter #6
Well, it has fixed it for me going on 3rd year now with no problem (knock on wood!). Good luck!
 

·
Registered
Joined
·
19 Posts
Do u know the exact name of this sensor or the part number...the idiots up at advanced auto and autozone for some reason dont knkw what the hell I'm talking bout or what the name could possibly be
 

·
Registered
Joined
·
1 Posts
hello yogi, please can you kindly send me the procedures you used in clearing the fault...I have a 2004 pilot and have the VTM4 alarm and check light ON permanently..Please kindly assist. thanks
 

·
Registered
Joined
·
1 Posts
Thank you for posting this DIY guide. I changed my temp. sensor on my 2003 MDX in no time thanks to this guide!

I was having the same problem with the VTM-4 light coming on randomly, fingers crossed that this fix keeps the light off.

The part I used was 48160-PGJ-003 which I purchased online from HondaPartsNow.com
 

·
Registered
Joined
·
10 Posts
OK, here is what you need to do to replace your VTM-4 temperature sensor, which makes itself visible and in the center of attention if YOUR VTM-4 LIGHT COMES ON
(not Check Engine light, this is important)
INTERMITTENTLY AND SHUTS OFF YOUR 4 WHEEL DRIVE (REAR DRIVE)
. Also, this throws a code 43 which you can check using a special procedure (search this forum to get it, it's pretty cool)
I've been searching here and this quoted from post #1 identified what I am experiencing right now but in addition to this I also have an intermittent ac temp light
I'm not sure if these are related to each other or not.
I have a 2003 MDX with 145,000 miles.

Ironically I also have a failed wheel speed sensor at the same time triggering my "ABS" "!" and "VSA"
 

Attachments

·
Registered
Joined
·
1 Posts
check engine/ vtm4/ flashing d5

i also have this atm sensor once in while ill get flashing d5 now i got a check engine light one code on there says clutch engagement sensor fault and my gas mileage is kinda all over place
 

·
Registered
Joined
·
1 Posts
Having trouble understanding how the VTM-4 Temp Sensor plug unclips. I don't what to break it. Do you push the clip down, pry it up, or what???
 

·
Registered
Joined
·
2 Posts
Any final PROVEN solution yet for the VTM4 code lighting up on ACURA MDX 02? I appreciate any tip, help from anyone. Thanks in advance!!!
 

·
Registered
Joined
·
1 Posts
No, but I got mine at the dealer. Not sure if it's an aftermarket item.
I went to online OEM Acura dealer. And found “Oil Temperature sensor”, or a “temperature sensor assembly (atf)”. Are either of those the part? Thanks
 
1 - 17 of 17 Posts
Top