Acura MDX SUV Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
So my 2006 MDX with 85k dash is lighting up. The odd thing is the lights come on if it sits for a few hours but upon restart (2nd start back to back) the lights go off? No CEL/codes are being thrown so how do I check wheel sensors, abs modules etr etc? Is there a special tool for pulling those non-CEL codes?
Thanks
 

·
Registered
Joined
·
64 Posts
Discussion Starter #2
Bump..anyone?
My battery tested good not running and running. I'm stumped. Ignition on (not started) lights are on. A quick off then back on and lights are gone??
 

·
Registered
Joined
·
200 Posts
I no longer have my manual in front of me today, but can look in the morning, so I am not absolutely positive.

Typically ABS, VTM, and VSA codes are not read via the DLC under the dash, these are their own computer systems, and they have their own computer connector, located elsewhere on the vehicle.
 

·
Registered
Joined
·
805 Posts
I no longer have my manual in front of me today, but can look in the morning, so I am not absolutely positive.

Typically ABS, VTM, and VSA codes are not read via the DLC under the dash, these are their own computer systems, and they have their own computer connector, located elsewhere on the vehicle.
They are indeed read via the DLC, but you would need the HDS from Honda (or a cheap Chinese clone). With that said, I have had my ABS light on/off for a while now and it is so maddening. It would go on for a few minutes while I was on the road. By the time I got home and hooked up the HDS, the light went off by itself and there was no stored code. It never stayed on long enough for me to retrieve the code.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #7
Last question- Will I need to purchase a software licence from Honda on top of this kit? Have you ever used this type of diagnostic tool before? I'd hate to drop $150 on it and need to but a license on top of it.
Thanks a lot!
 

·
Registered
Joined
·
1,178 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #9
My issue is with ABS, VSA, VTM-4. Your last post was related to SRS light issues. Do you know if a similair procedure to pull ABS/VSA codes? Thanks
 

·
Registered
Joined
·
64 Posts
Discussion Starter #12
No luck. I couldn't get the ABS light to go out in step one. I tried both jumping pin 9 and 4 as well as grounding pin 9 to the car and no luck. What'd odd is the lights would come on and all go off if I shut the ignition off and tun back on. But..I was messing around with the drivers front speed sensor cleaning it etc and not the lights stay on regardless of the ignition on/off. Guess I need to have a shop read my codes or but a scanner.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #13
Shop pulled a front left speed sensor and all 4 tires read 75 psi per the tpms which is strange. I replaced the speed sensor and the abs and tv lights went out but vas and triangle/! Come on after I start driving. Any thoughts for me now?
Thanks
 

·
Registered
Joined
·
48 Posts
I just went through this. I could reset the lights by using the jumper wire on pins 4 and 9 as described in the YouTube video. But as soon as I started driving they all came back. You have a bad abs wheel speed sensor. I was going to replace them one at a time until I got it fixed. I got lucky on the first one. Left front. Did the reset procedures again and it’s like new. Most shops have the high end reader needed to see which one is bad. You don’t have to go to Acura or Honda. I got my sensor at Advance for about $40.
 
1 - 16 of 16 Posts
About this Discussion
15 Replies
6 Participants
Tfret
Acura MDX SUV Forums
Acura MDXers Forum - a community where enthusiasts discuss engines, tires, service and everything you need to know about the MDX!
Full Forum Listing
Top