Acura MDX SUV Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
I have my X just a month and just hit 680 miles. I have been watching the gas mileage improve but don't know if my trip comoputer is broken or this is something that has happened to anyone else.

I was driving my daughter to the airport this morning (my 2nd highway drive)and it was a nice smooth run.The mileage started at about average 15 and got up to 18.2mpg. It hasn't budged from 17.8 in the average all day no matter how I'm driving, stopping, starting etc. The trip is is correct and reflects the mileage on my odometer since my last fillup and the range calculates but the average MPG hasn't.

One more question, the previous display shows a 3 day period and I'm not sure why it didn't reset when I filled up with gas since I have it set for reset with fuel.

Any help would be greatly appreciated since the husband can't be bothered.

One more thing..I found a nice ding on my door panel-any suggestions?
 

·
Registered
Joined
·
55 Posts
I had an issue where the mi to empty indicator was not reflecting my last fill up. The next time I got gas, I shut the X off and everything was working perfectly. Don't know if this is the same issue but here's my 2 cents.
 

·
Registered
Joined
·
53 Posts
sounds like the the fill up issue. Dont EVER fill the X without having the ignition in the off position.

next time you fill up it should fix itself
 

·
Registered
Joined
·
15 Posts
I had the same problem. Filled up with the car running and everything went crazy Averages/Range, etc, and it took two more tanks of gas to finally work itself out.
 
1 - 4 of 4 Posts
Top