Acura MDX SUV Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hey guys I'm a proud owner of 07 MDX with 234k miles currently. I've been doing maintenance on my own car since I brought and I've recently replace the inner and outer tie rod and also got alignment done at a local shop.

Now before I replaced these parts my steering wheel would jerks left and right and not return smoothly after making a turn so upon inspection I notice both the tie rod were bad and so I replaced them. Even after replacing both the tie rods my steering is still the same so now I'm scratching my head here on what's wrong with it. Is it my rack and pinion? Or something else on the steering system?
 

·
Registered
Joined
·
2,240 Posts
Check your power steering fluid or the pump and you may want to do a flush.

Question. When you change your INNER tie rods what did you used to bend the aluminum locking washer? I did the outer tie rods and it was pretty easy but the INNER I was not sure how to go about doing it especially when you need to bend that locking washer.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
858 Posts
Even after replacing both the tie rods my steering is still the same so now I'm scratching my head here on what's wrong with it. Is it my rack and pinion?
As bitter as it is, it probably is your rack and pinion. Yikes! I'm waiting for mine to go, but I'm on 170K miles "only" now, so I probably have some more time.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Check your power steering fluid or the pump and you may want to do a flush.

Question. When you change your INNER tie rods what did you used to bend the aluminum locking washer? I did the outer tie rods and it was pretty easy but the INNER I was not sure how to go about doing it especially when you need to bend that locking washer.


Sent from my iPhone using Tapatalk
Yes I did bend the lock washer that goes at the end of the inner tie tod. My fluid is topped off and I've done more research on the power steering pump and I hear a squeaking, whizzing noise occasionally.
 

·
Registered
Joined
·
2,240 Posts
Yes I did bend the lock washer that goes at the end of the inner tie tod. My fluid is topped off and I've done more research on the power steering pump and I hear a squeaking, whizzing noise occasionally.
You may want to check the low and hi pressure o-ring of the steering pump. If I were you I would replace both o-ring.

What did you use to bend the locking washer. The space back there is so tight and there is no room for hammering.

Or you could have a bad PS pump.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
You may want to check the low and hi pressure o-ring of the steering pump. If I were you I would replace both o-ring.

What did you use to bend the locking washer. The space back there is so tight and there is no room for hammering.

Or you could have a bad PS pump.


Sent from my iPhone using Tapatalk
I'm going to attempt to replace the two o rings and possibly
You may want to check the low and hi pressure o-ring of the steering pump. If I were you I would replace both o-ring.

What did you use to bend the locking washer. The space back there is so tight and there is no room for hammering.

Or you could have a bad PS pump.


Sent from my iPhone using Tapatalk
I used a hammer, but I was careful not to hit anything else. I'm going to attempt to replace the o ring on the pump as it seem like an easy job. If it comes to the pump should I go ahead and replace the drive belt as well? My drive belt is original.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #8
As bitter as it is, it probably is your rack and pinion. Yikes! I'm waiting for mine to go, but I'm on 170K miles "only" now, so I probably have some more
Are you the real AcuraAddicated bugdon? (Sorry I spelled your name wrong) your videos are very helpful sir. I hope you make a video one day doing the timing belt. I wi be using your video if I do the o ring, pumps, and drive belt.
 

·
Registered
Joined
·
2,240 Posts
I'm going to attempt to replace the two o rings and possibly

I used a hammer, but I was careful not to hit anything else. I'm going to attempt to replace the o ring on the pump as it seem like an easy job. If it comes to the pump should I go ahead and replace the drive belt as well? My drive belt is original.
While you’re at it why not. Come to think of it you may have loss drive belt tension and that is why your PS wheel is hard to turn or hesitate or squeaking because the PS pump is not giving 100% power. I might be wrong.

You used a hammer to bend the locking washer but how. There isn’t much room to get a tool in there. I need to look at it again how one could use a hammer and bang bang without ruining something else.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter #10
I used a small hammer and it did took me a while because I was hitting it slowing making sure I didn't hit anything else.

Edit: I forgot to quote.

Sent from my SM-N975U1 using Tapatalk
 

·
Registered
Joined
·
2,240 Posts
I used a small hammer and it did took me a while because I was hitting it slowing making sure I didn't hit anything else.

Edit: I forgot to quote.

Sent from my SM-N975U1 using Tapatalk
Did the old inner and outer tie make clunky sound when driving on bumpy roads?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
18 Posts
Discussion Starter #12
Did the old inner and outer tie make clunky sound when driving on bumpy roads?


Sent from my iPhone using Tapatalk
Yes especially the driver side. I still hear clunking noise coming from the driver. I'm going to inspect everything again on next oil change. I just hope none of my problems are related to the rack and pinion. That's one job I cannot do my self. Dang all these problems just started happening since last December.

Sent from my SM-N975U1 using Tapatalk
 

·
Registered
Joined
·
2,240 Posts
Yes especially the driver side. I still hear clunking noise coming from the driver. I'm going to inspect everything again on next oil change. I just hope none of my problems are related to the rack and pinion. That's one job I cannot do my self. Dang all these problems just started happening since last December.

Sent from my SM-N975U1 using Tapatalk
I still have clunky from both front left and right before and after I replaced the outer tie rods. Not sure the inner tie rods, lower control arm or something else. I don’t want to keep randomly replace anymore parts that might be still good.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
858 Posts
1 - 14 of 14 Posts
Top