Acura MDX SUV Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2,521 Posts
Discussion Starter · #1 ·
MDX is my wife's ride. I have not driven it for a while. Today however, I discovered that the speak will make a short 'pop' sound when I turn on the engine. It has happened twice already. Seems re-occurring. Anybody knows what is going on? Thanks.
 

·
Registered
Joined
·
3,389 Posts
I believe there was a TSB involving the Stereo AMP or HU? probably the issue is due to condensation. Solution IIRC was to replace the Amp or HU?
 

·
Registered
Joined
·
268 Posts
No way! I first started noticing the popping when I replaced the battery. Thought it was just the power starting to flow as I got a slightly stronger battery! Skirmich, do you know where I’d be able to find the TSB?

This was over a year ago I started noticing, haven’t really noticed much lately.
 

·
Registered
Joined
·
8 Posts
TSB 07-052
repaired my 07 1 year ago
Found used amp on ebay for $130 from LKQCCORP.com (Panasonic Audio AMp...says '09' on order- but it worked!
ordered required software update disk online for $16.00 or so from random acura dealer via amazon Part #07AAG-STXA101
weaseled the amp in - there was an installation video I think I found
amp is right side of glove box -remove glove box and dash 'under cover'
I am nominally mechanically inclined- but able to do myself
Now works great!!!!!
 

·
Registered
Joined
·
2,521 Posts
Discussion Starter · #5 ·
Holy ....

I was just asking very casually, thinking there might be a neat solution to solve a small annoyance. I really did not expect to read from the answer that replacement of amp might be involved. Gosh, I got more than what I asked for!

However, I checked my VIN number and it does not fall in the group that requires a new amp. That is super satisfying. I guess I shall just get that CD and update the software. BTW, I also believe having a new battery is part of the problem. I did not really noticed this before. I guess the Interstate battery from Costco is pretty strong? haha.

Thanks for the help. Googling the price of the CD now.
 

·
Registered
Joined
·
2,521 Posts
Discussion Starter · #6 ·
TSB 07-052
repaired my 07 1 year ago
Found used amp on ebay for $130 from LKQCCORP.com (Panasonic Audio AMp...says '09' on order- but it worked!
ordered required software update disk online for $16.00 or so from random acura dealer via amazon Part #07AAG-STXA101
weaseled the amp in - there was an installation video I think I found
amp is right side of glove box -remove glove box and dash 'under cover'
I am nominally mechanically inclined- but able to do myself
Now works great!!!!!
Hi since your car is already fixed and you probably do not need that CD any more, do you want to consider selling it to me? Thanks. PM me to let me know.
 

·
Registered
Joined
·
2,521 Posts
Discussion Starter · #7 ·
Holy ....



I was just asking very casually, thinking there might be a neat solution to solve a small annoyance. I really did not expect to read from the answer that replacement of amp might be involved. Gosh, I got more than what I asked for!



However, I checked my VIN number and it does not fall in the group that requires a new amp. That is super satisfying. I guess I shall just get that CD and update the software. BTW, I also believe having a new battery is part of the problem. I did not really noticed this before. I guess the Interstate battery from Costco is pretty strong? haha.



Thanks for the help. Googling the price of the CD now.


The disc arrived today.







It is published in December 2007. (My car was made in November 2006.). The installation has to be the easiest repair ever. Just follow the TSB and can be finished really quick. Since I did not have to swap out the amp, I did not need the Navi code. Just need the radio code.

It fixed both the pop sound when startup, and the radio turning on unexpectedly issues. Super happy.

In case someone needs this disc, please pm me. We can both save some money!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,521 Posts
Discussion Starter · #9 ·

·
Registered
Joined
·
3,389 Posts
Damn... My HU is eating CDs... Don´t even know if it will help if it gets stuck doing nothing.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top