Acura MDX SUV Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Rip-off? Repair shop wants to replace rear wheel speed sensor "wiring harness"

07 bought at 127K, 165K now. Emissions light has been on/off for a few months. Was told by the dealer that needed new catalytic converter LOL it doesn't have to pass emissions where I have it registered! Started showing SH-AWD indicators and going FWD only this past week. Code is P0134. Started researching, it looks like this is an 02 sensor issue.

Took into the local shop (good rep I thought) and asked them to look at it. They called me stating the SH-AWD is due to issues with rear wheel speed sensor and recommending replacing one sensor and a "Wheel Speed Sensor Harness" which requires them to drop the differential to access. They sent me fuzzy pics of a connector (attached).

They want 145 for the harness and 650 bucks to put it in. Is this even in the realm of possibility or is this a con?

Wouldn't the ABS light be on if the wiring/sensor was an issue?

Thanks.
 

Attachments

·
Registered
Joined
·
67 Posts
Regarding the code, O2 sensor and MUCH cheaper than a catalytic converter. I think it's very strange that they would say catalytic converter on that code.

Replace the O2 sensor yourself, and bookmark this link.

https://www.autocodes.com/p0134_acura.html

Regarding the other, I had an ABS error light on a BMW years ago. I hooked up a scan tool to look at which speed sensors were reporting and which.one wasn't.

I replaced the speed sensor that was bad (Very easy DIY), and everything worked perfectly after that.

Not sure if my current.obd2 reader can read sensors on mdx. Now I'm curious...
 

·
Registered
Joined
·
1,598 Posts
07 bought at 127K, 165K now. Emissions light has been on/off for a few months. Was told by the dealer that needed new catalytic converter LOL it doesn't have to pass emissions where I have it registered! Started showing SH-AWD indicators and going FWD only this past week. Code is P0134. Started researching, it looks like this is an 02 sensor issue.

Took into the local shop (good rep I thought) and asked them to look at it. They called me stating the SH-AWD is due to issues with rear wheel speed sensor and recommending replacing one sensor and a "Wheel Speed Sensor Harness" which requires them to drop the differential to access. They sent me fuzzy pics of a connector (attached).

They want 145 for the harness and 650 bucks to put it in. Is this even in the realm of possibility or is this a con?

Wouldn't the ABS light be on if the wiring/sensor was an issue?

Thanks.
i'm by FAR no mechanic, but something about their recommended fix (with regard to the symptom/error your 2nd gen MDX is experiencing)<br>smells like....<img src="https://media.gettyimages.com/photos/poop-picture-id186825263" width="10%" height="10%">
 

·
Registered
Joined
·
962 Posts
1. Buy yourself a basic code reader that can reset the codes also.

2. Clear the codes.

3. Whenever the ck light comes on, read the codes and note them in a log book. Then reset.

4. If the same code keeps coming back, it is probably valid.

5. If the P0134 repeats, try a can of "Guaranteed to Pass" and see if it revives the sensor.
 

·
Registered
Joined
·
739 Posts
Around here, a Check Engine Light comes on, they don't even attempt to do inspection. You get a 60 days repair required sticker.

Try fuel system cleaner like techron, gumout, or redline s1.

Sent from my LG-US996 using Tapatalk
 
1 - 6 of 6 Posts
Top