Acura MDX SUV Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have a 2003 Touring.

I had a problem with a power steering leack and pump noise. I checked and it seemed it was coming out of the top of the reservoir. I figured the red push-in cap was letting fluid around it. Replaced it and it didnt work.

I replaced the pump yesterday evening and fired up the car to let the fluid circulate. Once that happened I turned it left to right and it blew the red cap off the resevoir and fluid everywhere.

Then I took the cap off and started the car and saw the fluid flowing in the resevoir. I then installed the red cap to the reservoir and it starter making a noise in the pump and pushing the fuid up in the resevoir again!

It appears to me that it has air in the system.

Help and what is the solution?

Thanks
 

·
Registered
Joined
·
1,750 Posts
Most likely just a bad O-ring at the base of the reservoir. That's most often the cause of noisy power steering pumps (rather than bad pumps). A few bucks and a five minute job. Make sure that you only fill the reservoir to between the two (high and low) lines - mine was grimy enough I couldn't see the lines and over-filled it once.
 

·
Premium Member
Joined
·
5,255 Posts
The reservoirs have tiny filter screens in the bottom, and they can get clogged on occasion. The screens aren't removable....but you can clean the inside of the reservoir or order a new one for less than $20 if that's the issue.
 
1 - 3 of 3 Posts
Top