Acura MDX SUV Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
After doing a bit of research I've decided to buy a replacement feed line o-ring and power steering reservoir. The idea behind the reservoir is that there is a plugged screen that might be causing the pump to cavitate and make noise. However, upon buying a new reservoir at the dealership, it doesn't appear there is a screen in there at all. Is this supposed to be the case?
 

·
Registered
Joined
·
134 Posts
I believe the issue is that the factory o-ring material deteriorates, leaving gaps that allow air into the system. I am not aware of a screen.
 

·
Registered
Joined
·
1,179 Posts
I believe there is a mesh built into bottom of reservoir. It is not likely source of noise. Noise is caused by air bubbles in PS fluid. Air gets in where internal pressure is less than external air pressure, which is near the pump inlet fitting (oring seal). Numerous videos of this process on youtube for Honda/Acura V6's. Here's a typical example.


good luck
 

·
Registered
Joined
·
69 Posts
Replace the two o-rings, one is under the power steering pump and the other is on the feed line. This will remove the noise and save you $$ for unnecessary parts.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Thanks for the replies. The p.s. tank is cheap enough to replace as long as I have to empty it of fluid anyway. But I won't do it unless there's a screen in there. From looking at the new tank it's just a big empty container, no screen. I just want to confirm there is indeed not supposed to be a screen in there. If so then I'll return the part.
 

·
Registered
Joined
·
962 Posts
Recommend you flush all the fluid before installing the new tank, unless it's been done in the past few years. I use about 6 small bottles of Acura PSF to do a full flush.
 

·
Registered
Joined
·
6 Posts
I removed the hose to the inlet on the power steering pump and there wasn't a ring at all. I did the same thing to an 05 accord before and there was a ring.

Anyone else not see an o-ring on the return hose of the power steering pump? The noise seems to be gone but it hasn't been cold out.
 

·
Registered
Joined
·
1,179 Posts
I removed the hose to the inlet on the power steering pump and there wasn't a ring at all. I did the same thing to an 05 accord before and there was a ring.

Anyone else not see an o-ring on the return hose of the power steering pump? The noise seems to be gone but it hasn't been cold out.
The oring can stay in the pump. Use an oring pick to check. Otherwise you now know why air is leaking into PS fluid.

good luck
 
1 - 8 of 8 Posts
Top