Acura MDX SUV Forums banner
1 - 6 of 6 Posts

·
Premium Member
2008 Acura MDX
Joined
·
2 Posts
Discussion Starter · #1 ·
I have an 08 MDX with 239k on the dash. Car after getting up to 30-35mph it begins to hesitate. Codes are p300-306 I changed plugs and coils. Transmission specialist diagnostic test shows trans is good. Codes have gone away. It when I try to push it the sh-awd lights starts to blink. Any ideas?? I’ve also been suggested that cats may be clogged but if that was the case car would shut off if I’m not mistaken
 

·
Registered
Joined
·
2,494 Posts
I have an 08 MDX with 239k on the dash. Car after getting up to 30-35mph it begins to hesitate. Codes are p300-306 I changed plugs and coils. Transmission specialist diagnostic test shows trans is good. Codes have gone away. It when I try to push it the sh-awd lights starts to blink. Any ideas?? I’ve also been suggested that cats may be clogged but if that was the case car would shut off if I’m not mistaken
Valve clearance adjustment?
Clogged EGR passage?

Sent from my SM-G981U1 using Tapatalk
 

·
Registered
Joined
·
2,494 Posts
There's a couple diy here. Don't delay more. The valves can be burned

Sent from my SM-G981U1 using Tapatalk
 

·
Registered
Joined
·
1,534 Posts
more than likely clogged cats, rear one likes to fail esp.
 

·
Registered
Joined
·
103 Posts
My 07 had the check emmission light on during the colder parts of the year, code suggested 02 sensors, let it ride because it was intermittent.
After alomst a year, the sh-awd warning came on with the check emmission warning.
O2 failed completely, car goes fwd only.
New 02 sensors fixed issue...mostly
Still have an intermittent emmission warning, hasent put me into fwd only mode so far.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top