Acura MDX SUV Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
I have a 2007 MDX with 215k miles. I had a whine/rattle that seems to appear or get louder when turning the wheel or accelerating to higher rpms. I read the forums and googled the problem. All signs pointed to the PS pump and/or PS pump inlet hose O-ring.

Well, I installed a new PS pump last night, and the new pump had a pre installed new O-ring on the inlet hose connection. The noise actually got worse after installing the new PS pump.

What else could this be? I purchased the PS new from eBay, could I have gotten a bad one? Read some info on the tensioner spring pulley, could that be it?

I am getting frustrated because the noise is pretty loud at this point.
 

·
Registered
Joined
·
1,110 Posts
is it an Acura/Honda pump? Use honda PS fluid?
 

·
Registered
Joined
·
136 Posts
Discussion Starter #3
No - it was a generic replacement pump. I only needed to add a little PS fluid so I just used generic PS fluid from autozone.
 

·
Registered
Joined
·
136 Posts
Discussion Starter #4
At this point, you think I should try try a complete flush using Honda PS fluid?

Should I replace the resevoir? I saw that it has a filter cloth in bottom of it that can plug.

I don't believe my PS fluid has ever been changed, so it is original from 2007
 

·
Registered
Joined
·
1,110 Posts
Hopefully you only used a little bit of the new fluid as its the wrong type!!!!

Hondas require HONDA FLUID! They are very picky about fluid! Even if you buy generic you have to buy the "honda" generic. Most bottles will say do not use in honda products!

Buy the right fluid from honda and flush the system. The filter at the bottom of the tank is not replaceable and you'll have to buy a new one if it's damaged.

Did you check your power steering rack and all other components? Such as belt tensioner?
 

·
Registered
Joined
·
136 Posts
Discussion Starter #6
I don't know that there is anything wrong with the filter in the bottom of the resevoir. I was just asking if that commonly plugs up and I should replace it when I flush the fluid.

I have not checked the PS rack but I have not been losing any fluid and the noise appears to come from the location of the pump.

I think my next step should be to do a full flush of the fluid and replace with genuine Honda fluid. I will do that this evening the. Report back.

The vehicle is 10 yrs old with 215k miles so it definitely won't hurt to flush and replace with new fluid.

By the way, the power steering still works just fine it is just noisy (whine and rattle)
 

·
Registered
Joined
·
136 Posts
Discussion Starter #8
Everything I have seen/read just said to turn the wheel all the way left, hold 20 sec, turn wheel all the way right, hold 20 sec to purge air. I have done that
 

·
Registered
Joined
·
136 Posts
Discussion Starter #10
I did one drain and fill yesterday and noise was not perfect, but significantly better. The drained PS fluid looked terrible, almost black. I drove the vehicle yesterday evening to let the system circulate for a while, and I plan to do another drain and fill today (so that performs a good flush of the system). Hopefully this improves the noise a little more to the point I will be satisfied.
 
1 - 10 of 10 Posts
Top