Acura MDX SUV Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
My 2014 MDX has been sitting in the driveway for a couple days and today I went to start it and got the following errors:

All Wheel Drive System Problem
Anti-Lock Brake System Problem
Vehicle Stability Assist Problem
Hill Start Assist Problem
Trailer Stability Assist Problem
Power Steering System Problem

It's also doing something odd with the key as the car beeps when I get in it and it had not done that before.

Any idea what might be going on? It was running fine a couple days ago.

Thanks!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
I checked the fuses shown in this video and they're all OK. I also checked the bottom row of fuses and those are also OK.


I can't post links but the YoutTube video title is EASY ACURA, HONDA ABS, VSA, BRAKE, FCW, SH-AWD, TRACTION, CHECK ENGINE LIGHTS FIX!!!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4 (Edited)
I just changed the battery but the alarms remain. Will they need cleared out to go away? Can I do this with a handheld scanner or would the dealer have to do it?


Thanks again!
 

·
Registered
Joined
·
713 Posts
where are you seeing them? In the info panel? If so that is what happened not what is happening. Just clear those messages using the info button. You can't be moving or it locks out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
The messages show up on the dash screen and as lights in the instrument cluster.


I know for sure that the battery was low because the radio now requires the activation code. It's a 2014 and I had not changed the battery yet. The new battery is in and working.


I can't do anything with the info button right now because the radio is locked out, but I'll get the code tomorrow to get it fixed.
 

·
Registered
Joined
·
713 Posts
Correct. The late code is stored internally in the car. Pressing the rectangular audio power button and holding it for 2 seconds or more calls those codes up to the radio. Having a code on a piece of paper is obsolete and there only if the button fails.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Thanks all! The radio is up and running and I have a new battery. I'll drive it tomorrow and see if the codes clear out.
 

·
Registered
Joined
·
733 Posts
I had the same issue - I changed the battery and manually reset the warning codes and beep settings.

To reset the warning codes you need to get into the diagnostic mode (you hit 3 buttons on your consol) I cant recall which three but you can youtube it. once in there move around until you get to the codes section and take a photo of each one before you clear it to have a record just in case.

To change your beep settings go into your normal vehicle settings mode and configure how you want it to act. Lots of goodies in there.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
I found a bunch of links that show to hold in a few buttons to get in to diagnostics mode, but all of the references say to use the NAV button in addition to the other two. My MDX doesn't have navigation.


I also found a video that shows the use of the traction control off, e-brake, and brake to get in to a different menu but I can't turn off traction control because it's currently disabled.


I borrowed a scan tool from a guy at work and this model doesn't let me reset the codes.


I can't win on this one! :)
 
1 - 12 of 12 Posts
Top