Acura MDX SUV Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have 2006 MDX I changed the cluster and the fuel light is flashing and it shows that there no gas but I have a half tank
 

·
Registered
Joined
·
1,330 Posts
Sounds like there is some difference in the old and new cluster. You might be able to get it reprogrammed by the dealer, or it could be a hardware issue (best option then is to remove the low fuel lamp). ;-)
 

·
Registered
Joined
·
465 Posts
Not mentioned but I take it the replacement t is with a used cluster. If so, looks like clusters are grouped 2003 and 2004-2006. Don’t know about 2001, 2002.

If the year is correct, might want to check for good connectors/connections and for bent pins/terminals.

You might be able to pull the fuel gauge from the old cluster. Or, pull the items you need from the new cluster and see if they work in the old.

Maybe first a battery disconnect/reconnect in case something in the PCM memory needs to be reset? (Turn the lights, AC, and fan off and let it idle for 5-7 mins to relearn the idle.)

Good luck!
 

·
Registered
Joined
·
465 Posts
Well, that would point to an issue with the new cluster. What year is the new cluster?

If it’s used and is one from a 2004-2006 maybe the fuel gauge is defective, out of calibration, or bad connection at the connector/terminal. (The service manual has no info on recalibrating a fuel gauge).
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
3 Participants
LeftOverParts
Acura MDX SUV Forums
Acura MDXers Forum - a community where enthusiasts discuss engines, tires, service and everything you need to know about the MDX!
Full Forum Listing
Top