Acura MDX SUV Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
My 01' MDX just had the 45K scheduled maintenance service yesterday. Now I noticed that whenever the shift is in parking or neutral position, the engine idle speed jumps between 1000 rpm and 2300 rmp constantly with the noise like someone is playing with my gas pedal. I made sure A/C is off and the problem still present. Did anyone have similar problem?
 

·
Registered
Joined
·
1,769 Posts
Really weird symptoms ... Good thing you're still under warranty ... sounds like a trip to the dealer is in your future.
 

·
Registered
Joined
·
38 Posts
You might want to get your belts checked out, seems like they might be loose.
 

·
Registered
Joined
·
499 Posts
I had the same problem with my 00 Accord, it is the iddle swich/controller! Take it in.... My dealer had to order the part. Good luck!:1:
 

·
Registered
Joined
·
43 Posts
Discussion Starter #5
problem fixed!

Thanks to all of you who replied. Just like Casique suggested, the problem is caused by failure of the idle switch controller. Took the car to the dealer and they replaced the controller. After 30 minutes wait and my car looks OK now.

Other symptoms I observed while driving to dearler store: Check engine and VTM-4 lights went on, engine power surge and involuntary braking felt when driving 40~60 mph on D5 shift.

Luckily my car was still under warranty. I asked dealer whether the damage was caused by technician when he replaced my transmission oil. He gave me a doubtful looking and said it just happened at the time, not caused by them. Oh well, as long as problem is fixed at no cost, I am happy.
 
1 - 5 of 5 Posts
Top