Acura MDX SUV Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
336 Posts
Discussion Starter #1
I have an 07 MDX with Sport and RES.

I was having a problem with the memory seats/settings not working properly. I would unlock the car with my key and the seats and steering wheel would not move to the proper locations, nor would they move with the buttons on the door. And I couldn't control the passenger side mirror with the switch on the dash. I replaced the driver's side mirror actuator over the summer. So I replaced the passenger side actuator a week or two ago. That seemed to fix the problem for about a day or three.

The next step was to replace the battery, as it was the original one from the factory. I'm still having the same problems … the memory switch on the door has no effect. The passenger side mirror will not move with the switch on the dash. And now the passenger side windows will not roll down from any switch, nor will the sunroof open. The driver's side windows go up and down fine, no matter the switch. The symptoms are the same regardless of which key I use. The memory seats do pick up the radio and A/C settings. The passenger power seat works.

I'm stumped.
 

·
Registered
Joined
·
617 Posts

·
Registered
Joined
·
336 Posts
Discussion Starter #3
Also to note is that the tailgate intermittently does not work … whether from the remote, the button on the door, or pulling the handle.

And like I said above, I have replaced both mirror actuators in the past 6 months. But this is more than just a memory setting issue. Things are not working at all, period. Maybe a bad ground somewhere? A bad control module? I didn't see any of these issues until the temps dropped this winter.
 

·
Registered
Joined
·
336 Posts
Discussion Starter #4
Based on a few posts I came across, I went ahead and ordered the wiring harness that connects the driver's door to the body. Hoping this fixes the issue because I don't know what to do after that.
 

·
Registered
Joined
·
336 Posts
Discussion Starter #5
I feel like I'm talking to myself here ;)

In case anyone else has the same symptoms, I replaced the wire harness that connects the driver's side door to the body. It was a $20 part and took me about 30-45 minutes. This fixed the problem. Everything works as it should.

The job was fairly straightforward:
Removal
1) Remove the trim along the door sill and the piece just below the fuse box (where the hood opener handle is). I tried without doing this and I wasn't able to feed the new cable in properly.
2) Disconnect the two plugs above the fuse box (use the new harness as a guide).
3) Pop the harness clip above the connections. You'll be lying on your back looking up. Having a flash light and a long flat head screw driver help.
4) Disconnect the rubber seal on the inside of the door frame.
5) Pull the wire harness out - you may have to help feed it as you pull.
6) Disconnect the harness on the door. It's full of goop.

Install
1) Feed the harness through the hole in the door frame. Since you have the trim panels removed, you'll have no trouble getting the harness into the right spot.
2) Plug in the two connectors.
3) Connect the clip
4) Plug in the connector at the door and pop on the rubber seal.
5) Pop on the rubber seal on the door frame.
6) Reinstall trim panels.

Done. I had to reset the memory seat settings, but that was it.
 

·
Registered
Joined
·
6,347 Posts
Did you have any issues with broken wires in the harness?
 

·
Registered
Joined
·
336 Posts
Discussion Starter #8
Honestly, I didn't examine the harness. But it fixed the problem - so I assume there were broken or damaged wires. A lot of the wires are tucked into plastic sheathing so without tearing it apart you can't really tell. And what isn't tucked into sheathing is hidden behind the fuse box.

Other posts pointed me to this solution, but I didn't find any that detailed the removal/install process. I thought about taking pictures, but I had a rough weekend with my BMW and was in no mood to do much of anything.
 

·
Registered
Joined
·
6,347 Posts
Glad you were able to fix it and update the thread! :29:
 

·
Registered
Joined
·
4 Posts
Sounds like my 2008 mdx is experiencing the same issue with the wiring harness.
My windows wont roll down and locks wont work properly when the door is closed. While its open you can touch the wiring harness the comes out of the frame of the car and hear some clicking noise while the key is in the on position.
After reading the info here sounds like I need to change this wiring harness.
Did u guys by from the Dealer?
 
1 - 13 of 13 Posts
Top