Acura MDX SUV Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I bought an MDX and it had the check engine and VTM-4 lights on. P0401. I bought a new egr valve and I took apart the intake manifold. Cleaned all the little holes in the top of the manifold and cleaned the tubes going from the egr valve and the large tube going into the egr from the manifold. Cleaned the manifold really well too, it was really gummed up. I took carb cleaner and even a brush into the tube going into the egr from the manifold. The light still wont go away and I'm at my wits end here. Can someone please give me some guidance?
 

·
Registered
Joined
·
3,339 Posts
Is the code the same? sometimes you clear a code and a new one takes its place..
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Yep same same code. Insufficient flow. I also forgot to mention I did the valve adjustment. I actually have the valve covers off again now to check all the valves again just to make sure I didn't mess up anywhere.
 

·
Registered
Joined
·
1,751 Posts
Have you driven the car since replacing the EGR valve? Here's the "official" process (obviously, you'll have to use an OBD reader if you don't have a HDS or clone)...

 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
I have done the valve adjustment and rechecked all the clearances. Valve adjustment is not the issue here at least. I've been clearing the code with OBD2 scanner and have been driving it. It went away for a few days and just came back. I guess there is not much more I can do? Maybe it's because I didn't get an OEM egr valve.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Intake manifold egr ports, and the egr tubes are definitely clean. I used a brush plus carb cleaner and cleaned many times.
 
1 - 8 of 8 Posts
Top