Acura MDX SUV Forums banner

21 - 26 of 26 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #21
Good info ?. Was allways under the impression that the longer you drove the vehicle the alternator will top up the battery from a boost
 

·
Registered
Joined
·
472 Posts
I appreciate that you're active in your own thread, but we all have side bets on the original issue...kinda feeling like you lost focus here :) Terminal or battery? I need to know!!
 

·
Registered
Joined
·
58 Posts
Discussion Starter #23
Lol..well this is what I did so far. Clean both neg and positive battery terminals. Neg ground from battery cleaned. (Cost effective route) if problem happen again battery will be changed. Thanks one and all
 

·
Registered
Joined
·
268 Posts
Anyone out there using the expensive Optima battery? Just wondering if perhaps longer life can offset the higher initial expenditure.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #25
Just an update guys! Since I cleaned both positive and negative battery terminals and ground I've yet to incounter the dead battery issue I posted and asked for advice. Will check and see how it's holding the charge.
 

·
Registered
Joined
·
134 Posts
Just an update guys! Since I cleaned both positive and negative battery terminals and ground I've yet to incounter the dead battery issue I posted and asked for advice. Will check and see how it's holding the charge.
glad that fixed it. BTW a neighbor was having trouble thinking he had a bad battery, He charged it overnight, car wouldn't turn over. I went over, Battery voltage was 13.2, My charger would only put in about 2A, I grabbed the battery terminals, I could rotate both with some effort on the lead post. I rotated them to scuff up the terminals, Then it started right up. So.... he cleaned the terminals and tightened them, problem gone.
 
21 - 26 of 26 Posts
Top