Acura MDX SUV Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I made an automatic wiper delay board that is a direct replacement for the rain-sensing delay board found on the 01-06 MDXs. The rain-sensing delay board that's mounted up under the windshield near the rear view mirror commonly fails due to a range of problems. Many times people get their windshields replaced with non-rain sensing glass rendering the sensor inoperable. When the rain sensor fails to operate, the wiper have no delay feature leaving only two options - on-fast and on-slow. Both of these options are undesirable when it's drizzling or lightly raining.

My board gives back a user the delay feature with a range of 3-20 seconds between wiper sweeps. The wiper stalk on our MDX's has a sensitivity adjuster which tells the rain sensor how sensitive you want it to respond to rain droplets on the windshield. My delay board uses this adjuster to set the time delay. The lower range of the adjuster will set a delay of 3 seconds and the upper range will set the delay to 20 seconds - and everything else in between.

The rain sensor delay board also controls the wiper sweeps when the windshield washers are activated. It turns the wipers on for 3 sweeps when you spray the windshield. My device retains this function so in essence, you lose absolutely no functionality with my device.

My delay board is complete plug and play. There is no wiring, soldering, or any other modification required. Just plug it in, stick on double sided velcro tape, and enjoy.

I plan on selling these in the near future at a cost well below the cost to buy a new rain sensor.

The photos below are my prototype. The circuit board is complete but the case isn't. As soon as the case is finalized these will go on the market. I'm really curious to see in there's any interest so please post below if you think you might want one.

Thanks!!







 

Attachments

·
Registered
Joined
·
3,338 Posts
Sweet man! My X does not have a rain sensor so I dunno about this particular problem. Is it that common? for the sensor to fail I mean.

In any case Kudos for the Work and good luck on the endeavor.
 

·
Registered
Joined
·
28 Posts
I got my sensor working with advice from you and others (thanks to all), but might be interested in this for a long term solution. I'll be watching your post.
 

·
Registered
Joined
·
65 Posts
My 2004 Base just went to my son who is taking it up north to MBA school. I just replaced it with a 2006 Touring w/Navi. I imagine I do have the rain-sensing wipers though I haven't driven it in the rain yet. I'll have to check it out and keep this in mind!
 

·
Registered
Joined
·
11 Posts
Very interested! I've been messing with my auto wipers since I bought it. I've found it works fairly well if I hold the housing tight to the windshield but otherwise it's hit or miss. How much are you planning on selling them for and how do I get my hands on one?

Thanks!

Nick
 

·
Registered
Joined
·
28 Posts
My 2004 Base just went to my son who is taking it up north to MBA school. I just replaced it with a 2006 Touring w/Navi. I imagine I do have the rain-sensing wipers though I haven't driven it in the rain yet. I'll have to check it out and keep this in mind!
If you have a box at the top of your windshield to the right of the mirror base you have it, but I don't think they made a Touring w/Navi without it. Of course, it could be missing because we unknowingly bought an 06 Touring on which the windshield had been replaced with a non-sensing one. That's kind of a misnomer, because the windshield doesn't sense a darn thing, it's just that the rain sensing one has the clips that hold the sensor in place. Fortunately, the harness was still there, tucked in the upper console, but I had to find a sensor on eBay and then find a way to hold it in place (velcro did it for me although I had to use some special cement to get the velcro to stay on the sensor; stayed on the windshield just fine). For now, it's working like a champ.

Good luck with yours. :grin:
 

·
Registered
Joined
·
2 Posts
Would you still have some of these delay boards or units? How do I get my hands on one, or the circuit design if you aren't selling them? Previous owner put in a new windshield without the sensor and probably tucked the connector away. I can rewire it as needed. Don't want to get another brand new windshield just for the sensor and mounts. This is the fix I need if you have it!
 
1 - 10 of 10 Posts
Top