Acura MDX SUV Forums banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
2001 mdx, cruise not working and srs light on, but horn is working. is this clock spring issue or seperate issues? everything i have found searching says horn will not work either. thanks for any ideas
 

·
Registered
Joined
·
2,162 Posts
I doubt it's the clock spring then, if the other controls still work. It's possible of course, but I know some cars disable the cruise control when there is a problem with another system. Maybe that applies to the SRS?

I think it would be a good idea to get the car hooked up to a HDS (Honda Diagnostic System) laptop, which would allow you to check out the detailed status of the SRS and cruise systems. It might help to hook up a "regular" OBD reader to see if the car is throwing a code if you don't have access to a HDS (clones can be bought online for chump change, and make it a LOT easier to diagnose problems with a Honda / Acura).

You might be able to reset the SRS problem (if it was a glitch or temporary issue). Check out this link: http://www.mdxers.org/forums/18-maintenance/24861-need-reset-your-srs-light-diy-instructions-2.html
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
thanks for the reply, i did reset the srs light but it came back on about 20 mins into drive. can you recommend a hds clone? i see them around 100 bucks but not sure which are any good. thanks

i will try to reset srs and see if i have time to check cruise while it is off and report back
 

·
Registered
Joined
·
3 Posts
My clock spring went out in steps over six months. A new part fixed everything. I did have to reset the SRS once the new part was in.

Cruise control stopped working, then horn, and finally SRS light came on.
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
update- i was able to reset the srs light...don't know how long it will stay off, last time it didn't last long. took it for a drive and the cruise control still doesn't work. so i am assuming it is not clock spring. fuse is good so i have no idea?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
yeah i did check that, it is ok. took it out today srs light still off..AND cruise is working! so keep my fingers crossed. no just gotta figure out that slight float to the right when i let off gas..lol

thanks to everyone here and the advice, it is appreciated
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top