Acura MDX SUV Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a 2007 MDX, 180,000 miles, the package with all the bells and whistles. Have had intermittent battery drainage issues. Changed out for new HFL and eventually disconnected it (just because I never use it and wanted to rule it out) and have been through 3 batteries in 2 years. Have dash panel all lighting up intermittently, ABS, TPM, engine light, everything, then goes away. Radio and NAV always resets. Changed battery again this weekend and had a new ground wire installed. Now radio and NAV won't come on at all and when I get in and out of the car, no internal lights illuminate as they usually do, with the pleasant "Welcome" in the panel. Car shut off in the middle of the street yesterday while driving. And earlier on my way to work, transmission didn't want to shift, very slow start and then jerking every shift and then straightened up and worked fine. Of course, very safe. I found 40 NTSB related complaints. So, what gives?? Before I drive this thing into the lake, any ideas what else to look into?? Is this a computer issue, mis-messages being sent to all the other components or some strange electrical drain/problem, that I will never find. I've researched this issue until I'm blue in the face. I've had two honda accords, a honda civic, a Nissan Murano and a Ford Mustang. My F-O-R-D seems to be a better brand at this point. HELP!!
 

·
Registered
Joined
·
1,598 Posts
1.) are you the original owner of this 2007 MDX, or did you buy it brand new?
2.) do you keep accurate service records and has your MDX been serviced regularly when needed (and at the Acura Stealership or via independent mechanic, or yourself)?
3.) do you have (or have your HAD) an aftermarket alarm/remote start installed onto this MDX presently or in the past?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
No not the original owner. It was serviced by my boyfriend mechanic (now not together) so now I have serviced it. No aftermarket anything installed.
 

·
Registered
Joined
·
1,598 Posts
No not the original owner. It was serviced by my boyfriend mechanic (now not together) so now I have serviced it. No aftermarket anything installed.
this is tough one to comment on...:confused:
also sorry to hear that your stuck to deal with so many problems on this 2nd gen. MDX on your own...

with all the multiple issues/dreaded recurring electrical drains (in addition to the high mileage)- I would consider one of two options:
1.) take it into the most reputable Acura stealership to have them pinpoint problem(s) (at least you'll get a loaner car and some free coffee to knock you out of potential comatose caused by potentially high diagnostic fee's....BETTER yet- take it to the best independent mechanic (for Japanese cars) that you can find via Yelp, Angie's list etc.?.....

2.) consider cutting your losses- and sell the car? should be able to get at least $8K to $10K (I could be way off on the potential return value?....) :nerd:
 

·
Registered
Joined
·
733 Posts
Sounds like whoever did your ground shorted something out.

Here is what I would do:

Check to make sure the battery terminals are tight and clean.

Check the ground

Check the fuses

Drive it to auto zone and ask to check the battery.

I’d then buy an inexpensive multi meter
(walmart) and test the battery for parasitic power drain (YouTube how to)

If you have parasitic loss go through the steps to find where it’s coming from (YouTube it)

If that yielded nothing then and only then would I consider bringing it to a trusted independent shop. No point going to Acura, there’s nothing special they can do than a trusted independent shop can’t.

Good luck.
 
1 - 5 of 5 Posts
Top