Acura MDX SUV Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
07 MDX Elite(sport in the US?)

I hit the button for the hands free link, and I say something, it just keeps asking me to repeat it, so it picks nothing up, is this a mic issue? if so, is there any DIYs on how to get to it?
 

·
Registered
Joined
·
3 Posts
i believe your bluetooth module has died. this dead module could also start a battery drain on your vehicle. for my 2007, the replacement module is :39770-STX-A01. you can find these on eBay, etc.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
i believe your bluetooth module has died. this dead module could also start a battery drain on your vehicle. for my 2007, the replacement module is :39770-STX-A01. you can find these on eBay, etc.
Thanks for the heads up, I'll check it out, I found a doc on how to remove it, maybe the previous owner disconnected it after a battery drain? Right now there is none.

Is there any aftermarket options? maybe whole nav system :p

http://ww2.justanswer.com/uploads/acuramstr/2011-09-29_023242_binder1.pdf
 

·
Registered
Joined
·
8 Posts
bananax - search the forums on here. There is an easy do-it-yourself solution to fixing the hfl module yourself. It will save you a lot of money!

Look up "Bluetooth stopped working. Fixed." or one of my other posts for that specific forum.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
bananax - search the forums on here. There is an easy do-it-yourself solution to fixing the hfl module yourself. It will save you a lot of money!

Look up "Bluetooth stopped working. Fixed." or one of my other posts for that specific forum.
Hello Bober, thanks for the info, I did find that thread, baking 385 for 8 minutes. I'm familiar with this from doing it with dead videocards, re-flowing the solder or something :)

Thanks again
 

·
Registered
Joined
·
39 Posts
Discussion Starter #6
Update here: Baked it, it worked :) now it's acting up, but I'm not sure if it's the module or my phone ( happened right after my Note 4 updated to Android 6.0, so possibly the update broke something)
 

·
Registered
Joined
·
9 Posts
in my experience the baking worked but only temporarily. I replaced my HFL unit and it has been working well ever since.
 
1 - 7 of 7 Posts
Top