Acura MDX SUV Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1 (Edited)
Hi all.

2007 MDX Sport, about 120,000 miles.

Currently on vacation in Indio, California. "Check Charging System" and the little red battery icon lit up the dashboard. About half an hour later, battery completely dead in the parking lot of Autozone. Would not jump charge, or jump start. Bought a new battery, and had them test charging system. Alternator is apparently OK.

However, I still have the little red battery symbol displayed on the dash. Is this symbol supposed to disappear by itself if the system is OK? If I have to clear it, how do I accomplish this?

I really don't want the battery going dead again. If it had happened on a major road, the vehicle stops working in short order and could be hazardous.

Thanks for any helpful comments.

Jim
 

·
Registered
Joined
·
3,337 Posts
Check Ground cable for corrosion.. If in doubt replace the entire ground cable.
 

·
Registered
Joined
·
2 Posts
Hello,

Just purchased:
2007 MDX Tech 127,000 miles
- New Alternator and Battery installed @ 98k
- Acura Maintenance inspection completed @ 125K

I am having a similar issue with the "Check Charging System" indicator.
It randomly shows up for a flash but disappears and never stays lit longer than a second.
No disruption in performance and everything works fine including battery, stereo, navigation, and HFL.
It doesn't happen all the time. Sometimes not for a day or so.
However, it does seem to happen more often when my tank is near or during low fuel.
My initial thought was battery cables, loose terminal connection, or worse case scenario- the alternator.
Also, it does get rather warm inside my center console. Anyone know what that is?

Thank you so much for your time!
 
1 - 3 of 3 Posts
Top