Acura MDX SUV Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1

My mdx is a new to me 2008 which seems plagued with the "normal" electrical problems. I already baked my HFL bluetooth unit and it worked for a few days. It died and took out the battery with it. Before I baked the HFL, it was unplugged and the battery still died so I suspected the ac relay too. You see, after I jumped the stone-dead battery it started making this bad noise in less than a minute. The fans were off and smoke was coming up between the radiator and engine. I quickly searched for the source and couldn't find it so I shut off the engine. I got the camera ready and restarted the engine it to record video and captured it. You can't see the smoke though. The smoke might actually be refrigerant being blown out of the system from high pressure. It had a smell not like electrical or fire. I took the radiator cover off to get prepared for a new search. I also pulled the ac relay as a test. I never did get it to do that again but when I plugged in the relay the compressor came on. It just seems so intermittent. Anyways I'm ordering part number 39794-SDA-A05 relay which I hope is an improved relay and fixes this.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
My mdx is a new to me
That sounds like you put too much Freon in the system.
I doubt there was too much refrigerant in the system or that the previous owner touched the a/c. I figured this out googling the problem and I found other cars that use this relay and they described the exact same problem with dead battery, noise and smoke.
 
1 - 4 of 4 Posts
Top