Acura MDX SUV Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I am having no luck in troubleshooting my Awd in my 2004 Acura MDX. It started when my battery went dead and my husband jump started my car, then figured I needed a new alternator when the car failed to restart on its own. Took it to the dealer and had them replace battery and alternator, I also informed them of the vtm-4 light staying on and the vsa! comes on after I start to accelerate the car. When I picked up the car they told me everything was fixed even though the lights were still on. I called them back to make another appointment because my awd was not working when I noticed I could not get out of my stone driveway. No codes are coming up. I also had the rear differential oil changed and the rear sensor replaced. One other thing I did notice was that all my illuminating lights on the passenger side for the temp. control, gear shift, and heated seat burnt out at the same time. Took it into the dealership 3xs and they say they need to due more troubleshooting and I can't afford anymore hourly rates with no answers!! On a positive note, my gas mileage is better than ever, and car is running great!! Help, winter is coming and awd needed to get through the snow!!
 

·
Registered
Joined
·
3,338 Posts
Check ABS Sensors in wheels
Check Ground Cable from Battery to Chassis
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
vtm-4 light on & awd not working

Check ABS Sensors in wheels
Check Ground Cable from Battery to Chassis
Sorry for the delay in a response, wanted to do an update and yes I did check the ground cable, I did have a code for the front passenger sensor, change the sensor, reset the codes and still no awd. I also had the third seat removed and giggled the pins back there, still, nothing. All the fuses checked, battery cables pulled off and put back on. I do remember that the dealership wanted to pull my navigation system out to get to troubleshoot something in there but I don't know what it could be. Any suggestions would be great, winter is here and driving more difficult in snow. :laugh:
 

·
Registered
Joined
·
278 Posts
Sorry for the delay in a response, wanted to do an update and yes I did check the ground cable, I did have a code for the front passenger sensor, change the sensor, reset the codes and still no awd. I also had the third seat removed and giggled the pins back there, still, nothing. All the fuses checked, battery cables pulled off and put back on. I do remember that the dealership wanted to pull my navigation system out to get to troubleshoot something in there but I don't know what it could be. Any suggestions would be great, winter is here and driving more difficult in snow. :laugh:

I would just take it to a Honda dealer to pull all codes. Where I live Honda is sometimes cheaper than Acura for the same service, so I've learned.

I wonder if there is cheap way to get a hold of the dealer level Honda/Acura scan tool as I have with vagcom Lite for my Audi/vw. For only a $10 ebay cable that thing saved me a fortune!!
 

·
Registered
Joined
·
1,727 Posts
There are Honda Diagnostic System clones out there - they're not too cheap because it does require a hefty interface box, but they're a LOT cheaper than a few trips to the dealer. ;-) I've found it to be a great investment - it give you the option for doing a lot of things that make working / maintaining your MDX a whole lot easier.

I just looked on Ebay and see that there are now "cheaper, smaller" options - directly from China, of course - so I can't say whether they work or not (or include a workable HDS software copy or not). One thing to note is that the HDS clones run on an XP machine. That's fine with me, because the software for the VW and Volvo diagnostics I bought do too, and XP machines are cheap enough that you don't worry about using them in the garage. ;-) You might get away with running in compatibility mode using a newer PC, of course. Just one more variable when you're trying to get it all working, though.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Thanks for the feedback. I thought about taking it to a nearby Honda dealer to see if they can help and will take it in. Also I will look into the two other replies and let you know if I got a solution. I really like this forum, it has saved me a lot of time and money and also learning so much about my car. Love this car and want to run it and keep it as long as I can.
Happy New Year!!
 

·
Registered
Joined
·
1,727 Posts
1 - 8 of 8 Posts
Top