Acura MDX SUV Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have google Pixel 2 XL android phone. While using android auto with MDX 2019 TECH model, it is a painful experience. MDX looses connectivity with Android Auto randomly at every few minutes. Only way to make it to work again is to pull out the cable from phone, and insert again. I have tried different cables, uninstall, and install the app again, and so on but of no use. Android Auto is practically unusable. Any clue as to what could be wrong?
 

·
Registered
Joined
·
548 Posts
My guess your phone is not compatible. Acura publishes a list of tested and proven to work phones. Check to see if yours is on the approved list.
 

·
Registered
Joined
·
473 Posts
Yes, If you do a search you will find that the App is the Issue with the Pixel 2 XL "NOT the Car" Many have the same issue with the app and the Phone communicating with one another . The Android auto App Company claims to be looking into this problem.
 

·
Registered
Joined
·
29 Posts
When we had our 2018 Hybrid, the Apple Carplay started doing the same thing. No matter how many times I restart the car, it will do eventually do the same behavior. But when I restarted my phone, everything went well. Perhaps a phone restart will do the trick?
 

·
Registered
Joined
·
59 Posts
Had similar issues, do the following :

1. Update the AA/CarPlay Box software to version 17 (search for TSB, everyone can do this themselves via USB stick and Acura Firmware downloader available on interwebs or just go to your dealer).
2. Use original cables that came with the phone.
3. Plug phone is after the car has started and the Acura Link loading screen is done -> this is probably most important.

Now AA will be 99% reliable.
 
1 - 5 of 5 Posts
Top