Acura MDX SUV Forums banner

21 - 28 of 28 Posts

·
Registered
Joined
·
644 Posts
if you are checking a battery and the voltage is 20V then the voltage regulator is not working properly. 13.5V to 14.5V is a normal charging voltage on any battery. It won't charge lower and it will cook higher. At 20V I would expect battery acid to be everywhere around that battery. Hooking battery cables up backwards will certainly fry things.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #22 (Edited)
Just got my battery checked at Autozone. It's at 12.6V and CCA is 640 out of 650. Also, all the trouble lights suddenly got turned off on the way to Autozone.
Was this just a glitch? With arctic winter just around the corner here in Chicago, hope the battery is as healthy as the Autozone guy showed it on his device.
 

·
Registered
Joined
·
71 Posts
Hello, I can't say if it's the same as what you are seeing but I had a similar issue 2 years ago with my 2017. It wound up being a defective wheel sensor. Every warning on the dash and several additional warning messages came up that apparently share a light. It ran fine but shut off AWD and traction control in a snow storm. Mine didn't clear until I had it serviced at the dealer. Good Luck!
 

·
Registered
Joined
·
263 Posts
Hello, I can't say if it's the same as what you are seeing but I had a similar issue 2 years ago with my 2017. It wound up being a defective wheel sensor. Every warning on the dash and several additional warning messages came up that apparently share a light. It ran fine but shut off AWD and traction control in a snow storm. Mine didn't clear until I had it serviced at the dealer. Good Luck!
Hope it was a one time glitch and you never see it again!
 

·
Registered
Joined
·
1 Posts
All the lights in my 2016 MDX SH-AWD suddenly lit up, all wheel system problem, brake system prblem, VSA system, emissions system, hill assist, etc etc. Car is still running normally. All the maintenances are up to date. What is going on here?
I had this happen and it ended up being a bad parking sensor. It through an error and the system couldn't figure it out so it threw all warning lights on.
 

·
Registered
Joined
·
1 Posts
All the lights in my 2016 MDX SH-AWD suddenly lit up, all wheel system problem, brake system prblem, VSA system, emissions system, hill assist, etc etc. Car is still running normally. All the maintenances are up to date. What is going on here?
I had that problem too. I took a video of it and reported it. My problem was accompanied by delayed upshifting. The dealer said that all the lights on meant that the system was re-booting. The video showed the delay in shifting, and the dealership replaced a sensor in the transmission.
 
21 - 28 of 28 Posts
Top