Acura MDX SUV Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
837 Posts
Discussion Starter #1
I just had the new LTE Telematics unit installed that replaces the CDMA Telematics Unit.

I have the solid green connection light and I can call Acuralink. But the TU is not broadcasting my VIN to Acuralink. They can see my location but with no VIN they can't identify me which means I can't get any POIs and addresses that they send to the car.

The dealer is flabbergasted. They say the new TU should be plug and play.

Acuralink is clueless. They say wait a few days for the system to be updated which makes no sense. Network recognition should be instant.

Anyone else have these issues? Do I have a defective TU?

Traffic is working fine on my TU.
 

·
Registered
Joined
·
2,793 Posts
Hmm you're the first that I've heard of that is being switched to an LTE unit. Is this Canada only for now?
 

·
Registered
Joined
·
30 Posts
I received a letter a while ago indicating that I would be eligible for a new TU if:
I was still subscribed to AcuraLink when the 2G network in my area (Calgary) was shut down. The letter seemed to indicate that if you weren't subscribed then you are out of luck (i.e. once the 2G network goes down for good, you wouldn't ever be able to subscribe to AcuraLink). Pretty short sighted engineering to be honest...

In Calgary, we still have a 2G signal, so I had assumed Acura wouldn't do anything yet. E92: Did your system stop working completely or did you just ask your dealer to replace the unit in advance? My understanding is that Rogers (which I THINK is what Acura uses) is still keeping 2G around for a little while yet, so it would surprise me if Vancouver's network is already done. I searched to find an actual end-of-life date and couldn't come up with anything. I do remember getting an AcuraLink message a year or so ago indicating that folks in Thunder Bay were out of luck as 2G service was discontinued there.

I was hoping that the upgraded system would actually also bump up the software version of the head unit. I have an early build 2015 that wasn't eligible for the software upgrade provided earlier. Does any of that change, or is it just the modem that gets swapped out and everything else stays the same?
 

·
Registered
Joined
·
837 Posts
Discussion Starter #7
Maybe there's some sort of programming required to the TU to know the VIN?
Acuralink and the dealer are useless at trouble shooting this issue. I am going to have them install a new telematics unit. What a waste of money and time.
 

·
Registered
Joined
·
30 Posts
Acuralink and the dealer are useless at trouble shooting this issue. I am going to have them install a new telematics unit. What a waste of money and time.
Thanks for posting those documents.

When you say waste of money, I'm guessing you're just referring to the cost of your time? I.e. there wasn't any cost to you was there? Did you do the install yourself? Your other thread makes it seem like you did.

Also, did your AcuraLink stop working in Vancouver? As mentioned, it's still working in Calgary.

From the install instructions, it looks like it's just the modem GPS antenna and maybe bluetooth module. Too bad, I was hoping it was going to be the full infotainment system and I might get an upgrade. I guess I'm in no rush to get this done.
 

·
Registered
Joined
·
837 Posts
Discussion Starter #9
Thanks for posting those documents.

When you say waste of money, I'm guessing you're just referring to the cost of your time? I.e. there wasn't any cost to you was there? Did you do the install yourself? Your other thread makes it seem like you did.

Also, did your AcuraLink stop working in Vancouver? As mentioned, it's still working in Calgary.

From the install instructions, it looks like it's just the modem GPS antenna and maybe bluetooth module. Too bad, I was hoping it was going to be the full infotainment system and I might get an upgrade. I guess I'm in no rush to get this done.
Hi. It is a waste of money on Acura's part because they are going to have to supply another TU. Acura installed this under warranty. On the other thread, I was asking for instructions because I like to know what is involved before repairs are done to the car.

Service was spotty on CDMA. A lot of times it would not work, especially in rural areas.
 
1 - 10 of 10 Posts
Top