Acura MDX SUV Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
In the last weeks, I've been constantly getting ACC/LDW/LKAS errors in the dashboard. The ACC error is much more common, and comes with the code P0564. Googling for it, it says "Cruise Control Switch Circuit Malfunction".

Interestingly, it only happens when I'm moving the steering wheel. It doesn't happen all the time, but it's becoming more frequent.

Sadly, that disables the cruise control function completely, including the standard (non-radar) cruise control, until I restart the engine. That's very annoying.

I've scheduled an appointment to check that out.

I'm curious if anybody else here has noticed something similar.

I'm quite confident it's something in the steering wheel. Maybe a bad connection. All the switches are working perfectly, though.
 

·
Registered
Joined
·
2,102 Posts
Sounds like that's going to be a bad cable reel. I imagine that shouldn't be too hard for the crew over there in Fremont to figure out.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3
The car has been in the dealership for a couple days and they just can't reproduce the problem. :-( Murphy's law, of course.

They say they don't know what to do unless they see the problem themselves, despite dozens of pictures I showed them.
 

·
Registered
Joined
·
2,102 Posts
Maybe I gave Fremont too much credit? I think that's pretty easy to figure out, but maybe they're a bunch of dummies over there (I've actually heard this). Bring it to Pleasanton. Some pretty good techs over (no not me) there for sure.
 

·
Registered
Joined
·
2,387 Posts
The car has been in the dealership for a couple days and they just can't reproduce the problem. :-( Murphy's law, of course.

They say they don't know what to do unless they see the problem themselves, despite dozens of pictures I showed them.
I thought the cars retain the codes for awhile? I understand not being to replicate sometimes when there is no code. But when there is a code,this doesn't make sense. Don't mechanics have to be certified?
 

·
Registered
Joined
·
46 Posts
Discussion Starter #6
They asked me to get the car back, because they couldn't reproduce the problem in 4 days. They say they could see the code in the scanner, and they went through the Acura troubleshooting for that code and didn't find anything bad. They mentioned they have upgraded some firmwares somewhere. Not sure what it is though.

They asked me to go back if I see the problem again. It will probably happen sometime, I guess, since they haven't replaced anything.

I have a 2-week road trip coming up with this car. It will be very annoying to do that if the cruise control isn't working. :-(
 

·
Registered
Joined
·
837 Posts
In the last weeks, I've been constantly getting ACC/LDW/LKAS errors in the dashboard. The ACC error is much more common, and comes with the code P0564. Googling for it, it says "Cruise Control Switch Circuit Malfunction".

Interestingly, it only happens when I'm moving the steering wheel. It doesn't happen all the time, but it's becoming more frequent.

Sadly, that disables the cruise control function completely, including the standard (non-radar) cruise control, until I restart the engine. That's very annoying.

I've scheduled an appointment to check that out.

I'm curious if anybody else here has noticed something similar.

I'm quite confident it's something in the steering wheel. Maybe a bad connection. All the switches are working perfectly, though.
I am getting a lot of this too. Sometimes I get a warning that my LKAS is not working but it is working. A few times my ACC has stopped working but it comes back after I turn off and on the car. No software updates in Canada yet. Dealer says they can't help me.

I am due for an oil change soon so I will go ballistic on Acura Canada.

But the 9 speed transmission is awesome!!!!
 

·
Registered
Joined
·
46 Posts
Discussion Starter #8
Pay attention if that is happening while you're turning the steering wheel. My car is back in the dealership now. They're still trying to reproduce the problem, what's very annoying.

They suspect it's the cable reel, but they say Acura will only authorize the replacement when the dealer itself reproduces the problem. Pathetic policy.

Meanwhile, I've been driving a loaner, a brand new TLX V6. Nice car.
 

·
Registered
Joined
·
2 Posts
Having the same issue with my new 2016 MDX (ACC - P0564-F0, LDW no code and LKAS with P0564-15). Started happening around 1000 km. have 2000 km on it now and its done it about 25 times. Dealer has upgraded the software but still keeps coming up. Only once it did it 3 times in a row then was good for 2 weeks. Still waiting to get another apt to have it looked at. I don't think they have any idea what's wrong with it. Please post back if you've got your issue resolved. tks
 

·
Registered
Joined
·
2 Posts
found the issue with mine. It was a loose connector in the steering wheel. I noticed that the error would usually occur when I move the telescopic steering in as far as it would go.
 

·
Registered
Joined
·
1 Posts
I am having the same problem. 2014 MDX (Advanced and Entertainment Pkg). Did you get your issue resolved? My dealer cannot reproduce the problem either. They said drive back in the dealership when the error message comes up. Very annoying. It happens when I am turning the steering wheel or backing out. Curious to see if yours has been fixed.
 

·
Registered
Joined
·
197 Posts
2014 Acura MDX advanced, I'm having the same exact issue, but mine only happens when its super cold here in Michigan, Always happens early morning when i drive the kids to school and then when i restart the car it goes away, during the day when its warmer it doesn't happen. Usually its always ACC first then the other ones pop up. Was thinking of taking it to the dealer, but i'm already over my 4 year warranty. Anyone figure it out yet?
 

·
Registered
Joined
·
29 Posts
My 2018 MDX SH also did it twice now. The error will be retained in the dashboard if my iPhone has not been disconnected from the car. My wife thinks it's the Carplay interface that's causing this, but when I googled this issue, TLX and RLX (Hybrid) Owners are also experiencing this issue. Try searching "Acura Check emissions system/ electric parking brake issue". I will be visiting the dealership soon for routine maintenance and I will discuss this with the service advisor. I am hoping something will happen.
 

·
Registered
Joined
·
197 Posts
Anyone having any luck getting this issued fixed? its happening more frequently now even in warm weather, I just restart the car at it starts working again, but its getting annoying i gotta restart the car all the time.
 

·
Registered
Joined
·
15 Posts
Just another owner chiming in with the same issue, I haven't noticed the code but am getting same the errors every couple of months. Restarting the vehicle clears the message.

Been to the dealership several times and as they can not recreate the issue, they have not been able to resolve.

I have a 2016 MDX

In my situation, I keep thinking that this may be side effect have the tranny replaced for this 2016+ ZF9 Failure Due to Cross Contamination of ATF and Coolant - Tracking

But after reviewing this it looks like others are seeing it in other years as well
 
1 - 16 of 16 Posts
Top