Acura MDX SUV Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I replaced my radio with a jvc. For some reason the microlamps behind the A/C controls went out. I just replaced the bulbs by removing them from the plastic housing that you spin to lock in the lamp, and wiring new ones using the same plastic piece, still don't work. The orange lights for defrost and recirculate never went out. Temperature lcd has been working the whole time. Any ideas?
 

·
Registered
Joined
·
2,162 Posts
Most likely you knocked a plug loose, or accidentally pulled a wire loose. Or, you could have shorted out something putting in the new radio, and blown a fuse (if you're lucky) or burnt out a printed circuit board trace (if you're not lucky).
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
The lead going to that board is a harness with wrapped wire leads. And if the fuse was blown, the AC controls wouldn't work. I guess I'll be taking the board out and having a look.
 

·
Registered
Joined
·
2,162 Posts
Just for grins, I looked up where the power to the climate control lamps comes from. Strangely enough, it comes from the "Taillight Relay", which is the front middle of the six that live just ahead of the driver's left knee. They're fed by fuse #10 in the passenger's side under-dash fusebox (15 amp). You'd have a host of other things not lighting up if that was out though, including your glovebox light and your shift lever lights.

 
1 - 4 of 4 Posts
Top