Acura MDX SUV Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
This is a problem which has been reported in various forms for multiple years of the MDX, and with various possible solutions (most of which don't work in general, but do work in specific instances). The A/C (mode, AC, and fan buttons) do not work when pressed, and the external temperature does not display. Looking at the Nav. diagnostic screen shows the AC (climate control computer) has failed. Sometimes re-loading the software from the disk fixes the problem. On my 2002 MDX, this didn't work. What does appear to have worked is pulling fuse # 3 from the drivers side fuse box and then putting it back in (the fuse is still good). This fuse controls the AC and fan relays. Why this worked I don't know. It's possible that it's coincidence. It may also have caused the climate control to reset itself. Does anyone have a good, authoritative, solution for this problem?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
The climate controls have been coming and going every few days now since the initial post. Pulling and resetting fuse # 3 is not the solution, just a coincidence after all. I had the car into the Acura dealer, who went to pull the climate control computer to test against a known good one, and of course it started working when he pulled it. So they cleaned the connectors and put it back in, and it worked for about 2 days. It looks like I'm going to have to try and replace the unit and see if that fixes the matter for good.
 

·
Registered
Joined
·
1 Posts
I have the exact same problem on my 2003 MDX. The A/C (mode, AC, and fan buttons) go on and off and there is no real pattern on when they would behave one way or the other. I might have to take it to the dealership to have it checked. Please keep us informed if you were successful in the diagnosis.
 

·
Registered
Joined
·
4 Posts
Climate controls

I have had the same issue with the control buttons and the outside temp not displayed off and on for some time. I am very interested in what you find as a fix. I did try removing and reinserting the number 3 fuse without success. I have also had trouble with the a/c freezing up when used hard. Today I changed the cabin air filter that was really bad. Could this be why the freezing?
 

·
Registered
Joined
·
7 Posts
Same thing here

My controls are doing the same thing. Good thing the Auto A/C controls work fine.
Does anyone know the solution to this? I think a bad Climate control unit is the problem, but I want to make sure.

Another question:

Does anyone know where I can order the CCU? I can not find it on any of the Acura Parts Catalogs online.

I really want to get this fixed while I have everything taken apart for a Transmission swap this weekend.

Hope someone can help.
G
 

·
Registered
Joined
·
4 Posts
I know this has been a quiet topic but I seem to have started seeing the same weird issue(s) with our 2004. The manual mode will not let you select buttons nor does the outside temp display. At times it goes into a "loading software" mode and later requests the pass code which takes 1 out of 4 tries. When it does finally start working (navigation) the top 1 inch of the screen will flash the fan speed etc. then go away. Diagnostic mode does show the CCU as faulted. I have gone through re-seating connectors, tested for 12vdc as well as verified good grounding at all units. I may need a CCU but my gosh they're expensive ( > $250) just to use shot-gun method. Nearest dealer is an hour and a half away and we are on to tight a budget for guessing. I would entertain the idea of loading the software manually via CD as mentioned above. How would one obtain this CD and how to?
 

·
Registered
Joined
·
166 Posts
You could take the circuit board out of the ccu housing and look for some physical signs of failure. Typically a section of the pc board will have gotten hot and partially melted, the connection might be there when the board is at a certain temperature and then lose connection as it heats up. If you can identify an obvious problem on the pc board, you won't be guessing at the fix.
 

·
Registered
Joined
·
4 Posts
Thanks for the reply FJR1300. I did remove the circuit board from the plastic housing to do just that. Also smelled it to check for unseen burnt components. Every thing looked/smelled fine.
 

·
Registered
Joined
·
1,179 Posts
A used part using car-part.com to find a local part in a salvage yard. Note, the search for AC controlls may produce a veriety of parts. You will have to call the yards to get the part you need. I suspect you can find for < $50 easy.

good luck
 

·
Registered
Joined
·
2 Posts
Hi ...I have an 03 MDX...my AC is blowing hot air and the AC controls on the navigation screen don't work either. Was told the port on the back of the navigation screen is not holding enough tension and is unable to send a signal resulting in the compressor not kicking in. Was suggested to send the unit in for repair and the repair window is 4 to 6 weeks. approx $800
 

·
Registered
Joined
·
5 Posts
Hi. I picked up my X last week and dropped it off at my cousins shop for a week. I just got it back and my ac buttons are on again off again. They were working when I dropped it off. I googled it and found this. My cousin did disconnect the battery. I'm going to try this tomorrow to see if it does anything.


Hi,

My mechanic had to unplug the [COLOR=green !important][FONT=inherit !important][COLOR=green !important][FONT=inherit !important]battery[/FONT][/FONT][/COLOR][/COLOR] of my Acura MDX 2002 for repairs. Since he has re-plugged the battery, the trip computer his not working, has nothing comes on on the screen. Neither are the Mode, A/C and fan buttons underneath the trip computer.

- I have checked the different [COLOR=green !important][FONT=inherit !important][COLOR=green !important][FONT=inherit !important]fuses[/FONT][/FONT][/COLOR][/COLOR] on the driver and passenger side (fuses 9-10 &11).
- I have checked the brightness.
- I have unplugged and re-plugged the battery...

I have the card withe the 4 digit code for the anti theft... but the screen is not ''asking'' for the code.

* The radio in my MDX is not the original one ( i don't know if it's important or not)

TY
Joe
Submitted: 1 year ago.
Category: Acura





Expert: Kyle N. replied 1 year ago.
Hi,
My name is XXXXX XXXXX X'm an expert here at JustAnswer.com. I'd be glad to help you out with this problem.

Joe,
Try disconnecting the negative then positive [COLOR=green !important][FONT=inherit !important][COLOR=green ! important][FONT=inherit ! important]battery [/FONT][COLOR=green ! important][FONT=inherit ! important]cables[/FONT][/COLOR][/FONT][/COLOR][/COLOR] then touch the [COLOR=green !important][FONT=inherit !important][COLOR=green !important][FONT=inherit !important]cables[/FONT][/FONT][/COLOR][/COLOR] together for about 5 minutes. This clears the vehicle back to default and could fix this glitch. After 5 minutes put the positive then negative battery cable back on the battery and tighten them up then see what happens. You'll need to enter the code but it should all come back.

Hope that helps.

Kyle N., ASE Certified Tech
Category: Acura
Satisfied Customers: 5179
Experience: Master ASE Tech, Ca. smog lic


Kyle N. and 2 other Acura Specialists are ready to help you
Ask your own question now




Customer: replied 1 year ago.
Hey Kyle,

Just did what you told me and it worked. Tanks so much... The dealer wanted to sell me a new one for about 1000$ - 1500$.
 

·
Registered
Joined
·
1 Posts
I had the same problem and I was able to get the controls to work again by carefully cleaning the navigation DVD with soap and water.
 

·
Registered
Joined
·
2 Posts
Where do you find the navigation CD? I did get the AC portion to work on the panel by doing the reset with the cables. Now I notice that the clutch isn't engaging. So is the compressor bad, or is there another issue? I'm a girl trying to keep from getting taken by the dishonest mechanics, since they don't have the same answer. It's paramount to going to a Dr and having them tell me, I need to have surgery, and they can't agree on what the part is, that they're taking out. ;) Scary. I don't have money to spare.
 

·
Registered
Joined
·
2 Posts
I had the same problem and I was able to get the controls to work again by carefully cleaning the navigation DVD with soap and water.
Where do you find the navigation CD? I was able to get the AC options to work on the display panel, by using the cable reset above. Thanks. But now, I'm trying to keep from getting taken by dishonest mechanics, telling me different things. I discovered that the clutch is not engaging, so now I'm trying to figure out, is the compressor bad, or is it something else? I'm a girl who doesn't have money to spare, but am willing to do what I can do myself. I've got an appointment tomorrow, to take it to another mechanic, but the more I know, the better equipped I feel I'll be to know what is actually wrong with it, so maybe I can get it fixed, since it's getting hot in Phoenix, this week. I'm not a sissy who can't tolerate the heat, but others riding in my car feel differently. :)
So sorry for posting too many times. I'm new at this.
 

·
Registered
Joined
·
4 Posts
Climate controls

I have had the same issue with the control buttons and the outside temp not displayed off and on for some time. I am very interested in what you find as a fix. I did try removing and reinserting the number 3 fuse without success. I have also had trouble with the a/c freezing up when used hard. Today I changed the cabin air filter that was really bad. Could this be why the freezing?
leaks thing here. Can’t control Ac or heat fan settings, pretty important, on off on off. Too hot too cold. Damn Goldilocks. Any cost effective fix.
 
1 - 20 of 22 Posts
Top