Acura MDX SUV Forums banner

21 - 36 of 36 Posts

·
Registered
Joined
·
2 Posts
I have bought a brand new 2016 Acura MDX in February 2016.

On June 20th, I had the first experience of the problem with dashboard showing that there is Transmission, Emission, and all other system problem. The car stopped on the road. Later it started but continue to flash the warnings.

This same problem occurred second time on September 6th and at the time, I was starting the car and it won't even start. Later it started but continue to flash the warnings.

I took the car to Performance Acura dealership on these both occasions and it shows up later.

Again, Third time it happened on October 30th. Now the dealership is going to fix again.

Anyone else having a similar problem with 2016 MDX?
 

·
Registered
Joined
·
1 Posts
2016 MDX same problem here -3500 miles on the car

We bought ours September of 2015. At 3500 miles we had the light issue. They said it was the fuel injectors, they replaced them. I got a call from the service department the problem still exits and they are now going to replace the rear cylinder head. This is my first and last Acura.
 

·
Registered
Joined
·
1 Posts
I have a 2016 AWD Tech Entertainment, bought in May 2016. Less than 5000 miles, and I have experienced the same issue.
Car is at the dealership now for 2 days, yesterday they updated the software after getting the misfire code

Today the issue still persists, and they are doing a valve adjustment?

The service advisor told me that 5 cars have been in with the same issue just this week alone. One car has been there an entire week with no resolution!
 

·
Registered
Joined
·
3 Posts
Here is the work order from the dealership:
Inspect for check engine light on, check engine light flashing and every warning light in the vehicle is on, would not accelerate over 35 mph.

This is what the dealership found:
Cause: Light on – 123505 Diagnostic Trouble codes/Programmed fuel injection (PGM-FI) – Retrieve codes with the HDS, Read Data, 74 – WA3.
Inspected for check engine light on, found DTC P0303 (cylinder # 3 misfire) recorded freeze data and cleared codes, at time of inspection vehicle was running perfectly, test drove vehicle twice on extended test drives and engine ran perfectly, no DTCS are reset no problem is present at this time.

Does anyone know what this info means?

Acura District Manager said they would not give me a new car. If this happens again, I will ask for a factory rep or tech guru to look at the car while it's at the dealership.

This is very unsettling. The next time this happens I could be driving on the freeway and cause an accident. How can Acura manufacturer a car and their dealership not be able to fix it?? The car does not function well - it goes in to limp mode.

Plus this is a $50,000.00 car!!

Where is their integrity?? I bought this car in good faith because I believed Acura is a good brand, but have found this not to be the case.

Thank you everyone for all of your responses :)
Hi Ifm,

Did u get any solution? I get the same issue on my 2016 Acura MDX so need your advice. Thanks.
 

·
Registered
Joined
·
3 Posts
I am desperate at this point! Our 8 month old car with less than 13K on it has been sitting in the shop for almost a month now since the 9 warnings lights came on when we were out of town.

BTW do not call roadside assistance - you pay a premium expecting to be taken care of but we were kicked to the curb and have been trying to fend for ourselves ever since with no resolution.

The service advisor have given me all sorts of diagnosis under the moon - it almost got better and better with time. These are the "experts" we depend on to give us qualified answers on our technical issues.

We are Vancouverites who were in Whistler for Canada long weekend - stranded over 126km away from home.

Here are is my dealership's service dept best "guesses" on the issues with these warning lights:
1) rodents
2) we left something on (lights) or doors weren't closed
3) low voltage battery
4) alternator
5) fuel pipes and injectors (check out the quote below that I copied from his reply to me - the car is COLD!...hmmmm we leave in Canada - boy oh boy are we in for a ride Acura) anyone else hear a lemon knocking on my door?!!! Prior to this he asked me what type of gasoline I put in my car - an idiot could answer that ...let me just say "premium"!

The lights would come on upon trying to start the vehicle when it is cold. Upon shifting gears from park to drive or reverse there was minor delays and the tachometer would bounce.

We contacted tech line again and was instructed to replace the injectors and fuel pipe. The injectors will be arriving in a couple of days. The fuel pipe is currently on back order


Back order that they cannot give me an ETA for...apparently a "critical back order" has been placed and believe it or not Acura does not carry stock of this part that costs no more than $200. I am absolutely livid that these experts after all these time could not definitely narrow down the issue and I will in the near future have to deal with the fear of driving a car I totally lost confident with carrying my family.

When all 9 warming lights came on - one with the brake system, the service advisor deemed it being safe for me to drive down from Whistler to Vancouver. I have been dealing with the service dept at the dealership to no avail, hence I have been in contact with Acura Canada but the product specialist there is also a little behind on his times in terms of customer service.

Anyone else been in my shoes and have any advice to offer? Obviously when a car is off the lot - lemon or not we dont' have many options here in Canada compared to the US.


Thanks!
Hi Sassy,

Did u get any solution? My acura mdx 2014 also have the same kinda issue?
Thanks!
 

·
Registered
Joined
·
1 Posts
this is an old thread since 2016 but still no resolution?

I found this old thread because i bought an used 2016 MDX elite last year. It's been happening on and off. I have brought the car to the dealership over 4 times and still not fixed. i went and bought extended warranty just because of this issue.
Would anyone from the previous posts kindly provide us some kind of updates for the issue? Or this issue just never gets resolved and you guys all sold your cars.

Thanks
 

·
Registered
Joined
·
2 Posts
Have owned a 2014 MDX Navi for over a year, same issue on and off (Lane departure, emission, fcw, etc. warnings + drives rough when this happens, maybe cause of the auto-limiting the speed). When restart the car, most of the time the auto-limiting goes away, but warnings may stay for another day or more, then they go on their own. Been to dealership and independent car shops multiple times, nobody can help. The issue may happen multiple times a day, or may not happen for months.
Sometimes the car has hard time starting, but will start eventually.
Posting this to keep the thread going.

others are suggesting to replace Wheel Speed Sensor - haven't tried that solution yet, but you need to know which one to replace if that's the root cause
 

·
Registered
Joined
·
2 Posts
was able to fix my issue by replacing high pressure fuel pump

symptoms:
on a highway, check engine would come up randomly, the car would lose the power, but still would run shaking and not accelerating. The following errors would come up:
vehicle stability assist problem
engine problem (P0087)
lane departure problem
forward collision warning
Workaround: stop the engine, restart the car. During the next start, the engine would have a very rough stat, but then would start. Another 4 errors would come up:
emission system problem
power steering problem
lane departure problem
hill start assist problem

The problem started happening after about 2 years. It was not so bad in the beginning and would only happen once in a few months and would go away after restart. However, it started happening more often and often, so lately, it's been happening every day, multiple times.

We've been to Acura many times, been to independent mechanics who scanned the vehicle many times as well. Acura dealership wouldn't help at all - they would restart the vehicle, reset all codes and say - see, it doesn't come back. Then we ran out of warranty and they said that we have to pay for diagnostics. After that and no help from independent mechanics, decided to start replacing fuel system components.
Here is what we replaced:
- Engine Control Unit (ECU/Brain)
- Fuel pump (the one in the tank)
- vapor canister sensor
- Exhaust Gas Recirculation (EGR) Valve
finally, one of the mechanics suggested that P0087 is fuel pressure on the rail (which I also saw in google, but didn't really understand what that is), so it could be high-pressure fuel pump, which is very rare, but most likely - a sensor that is on the rail.

I just went ahead, bought a new high-pressure fuel pump and had an independent mechanic replace it
BINGO! the problem is fixed now. don't know how long it will last, but I'm certain that right now it's fixed, cause it would come up multiple times a day, now it hasn't for a while.

For others with same problem, MDX can take two high-pressure pumps:
Denso 167905J6 (original)
and
Spectra FI1574
 

·
Registered
Joined
·
2,584 Posts
Thank you for your due diligence. Now i have to add the hpfp onto my watch list lol ugh

Sent from my Pixel using Tapatalk
 

·
Registered
Joined
·
3 Posts
I have 2016 MDX (basic pkg) and ran into issues mentioned last week. Every single light that you mention came on. After restarting twice, they went away. Local AAA wouldn't help as there's no code on to go by. MDX is out of warranty but I did purchase extended so let's see what dealer has to say. They say they can tap into code history even though everything's reset. Will update based on their feedback.
 

·
Registered
Joined
·
823 Posts
Interesting that this thread popped up. My 17 Advance is at the dealer now. Thursday morning at start up all dash lights came on and display cycled through problems. I restarted three times and still had issue. I dropped it off at the dealer Saturday and dash lights were on the entire way. I detected no negative impact on driving the vehicle to dealer. I have loaner (19 MDX A-spec) so no rush, but will post solution.

Update: Just talked to dealer. They are replacing throttle body, and car should be ready tomorrow. I asked why that would cause all lights to come on, and was told that people have become so complacent when just a check engine light comes on that multiple lights are triggered to get driver's attention.
 

·
Registered
Joined
·
482 Posts
”and was told that people have become so complacent when just a check engine light comes on that multiple lights are triggered to get driver's attention”.
That sounds a lot like “we have no idea - so we’ll just tell you this”

The Check engine light always gets my attention and I happen to know when it’s a bad code that needs immediate attention the check engine light blinks for that purpose.
 

·
Registered
Joined
·
3 Posts
I have 2016 MDX (basic pkg) and ran into issues mentioned last week. Every single light that you mention came on. After restarting twice, they went away. Local AAA wouldn't help as there's no code on to go by. MDX is out of warranty but I did purchase extended so let's see what dealer has to say. They say they can tap into code history even though everything's reset. Will update based on their feedback.
Quick update...Dealer service tech indicated all cylinders misfired per their diagnostic. They kept MDX for couple of more days for additional troubleshooting and determined fuel injector malfunction. I had extended warranty so this was a covered repair. IMO they could have cleaned them as well but perhaps given warranty, they chose to replace entire set. Spark plugs looked healthy so they were not replaced (They would have been out of pocket expense given ext warranty doesn't cover routine maintenance).

Also heard of a similar case from a friend who was able to get around this by replacing all spark plugs on his almost 200K TLX. So it seems all issues center around "check engine" code which then cascades to other codes to get driver's attention. Dealer service manager also confirmed the cascade function to me.

thanks.
 

·
Registered
Joined
·
1 Posts
2015 MDX Warning lights

I have a 2015 MDX and all of the warning lights (lane departure, fwd collision, check engine, transmission,etc) started coming on randomly. The car still seems to drive fine. It first happened 2 years ago and then didn't happen again until about 1 month ago and the frequency increased a lot. The initial diagnoses was low battery voltage however after replacing the battery it started to happen again (even the same day) and got more frequent over the last month. The dealer kept it for a week and decided the problem was a faulty output shaft speed sensor and replaced that. It has been about a week and no problems since then but I was curious if this sounds legit, if anyone else has had this problem and if replacing the speed sensors resolved the problem permanently?
 
21 - 36 of 36 Posts
About this Discussion
35 Replies
21 Participants
Jules
Acura MDX SUV Forums
Acura MDXers Forum - a community where enthusiasts discuss engines, tires, service and everything you need to know about the MDX!
Full Forum Listing
Top