Acura MDX SUV Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello all,
I am looking for help. My battery died in my 2010 mdx and when it was jumped the 120 amp main fuse was blown. After replacing the battery and fuse, the keyfob, lock buttons, pwr tailgate, nav screen and driver memory are all not working. I have checked all fuses and have replaced ones that looked old even though the only blown fuse was the system main 120 amp. I am thinking of replacing the driver door sub wire harness, but I'm wondering if there's a bad module or relay that is the real cause. Can anyone give some idea on how to troubleshoot these problems without going to the dealer? Thanks in advance for any help!
 

·
Registered
Joined
·
3,200 Posts
You can try cycling the door between open and closed to see if it is the driver door sub harness… Sometimes putting the door at a certain angle makes the wires contact and work.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Well it seems that it may be thessib wire harness. After I write the forum post, I looked at the sub wire at the door connection and I see copper out of the top of the plug where a black wire ends just above it. (I'll try to update with a photo) And I actually got my tailgate lock to work for a moment after re-seating the door side plug. Could this sub wire affect my nav screen and my reverse camera as well?
Thanks for the suggestion, I think I'll order this part. Is there a preferred website to use ir is Amazon ok?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Very sorry for the spelling errors! I am posting from my phone while I am looking over my mdx...
 

·
Registered
Joined
·
3,200 Posts
IMO I dont think the sub harness can affect the NAV as there is nothing concerning the NAV connected to that harness.. That might be a separate issue.
 
1 - 5 of 5 Posts
Top