Acura MDX SUV Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello- I've been trying to research what is going on with our Acura MDX. The last few days I noticed it to be extra whining sounding as I drove but I thought it might just be working harder since I had the A/C blasting. Then yesterday evening the "Charging System P0562" Indicator came on and I was stopped at a stoplight and I went to go and my car wouldn't go. After pressing on the gas for a bit it finally started moving. But it did this every time I stopped then a bunch of indicators started flashing, and when my foot was off the gas pedal all indicator lights, nav system, and radio went dead.

We just bought a new battery about 3 mo ago because it kept dying due to what we thought was the Hands Free Link system draining the battery even when the car was turned off. My husband replaced the Hands free link system too.

Today I went to drive my car to an auto body shop and it would not start, we jumped the battery and kept it attached for awhile, put it in reverse to back out and it died. Early research I've done shows it could be the alternator? Also there is a small oil leak, could this be related?

Thank you in advanced
 

·
Registered
Joined
·
6,347 Posts
Alternator would be my first guess but that guess is worth what you are paying for it! $0. Good luck with everything.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
UPDATE: towed to the shop, found out problem was the alternator. $410 to fix including parts and labor. Thanks phins2rt for your reply!
 
1 - 3 of 3 Posts
Top