Acura MDX SUV Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Just got the SUV and the outside and inside our near mint. But please take the time to help me with a few issues if you can.
1. The HFL doe snot work - i disconnected it because i thought it was draining the battery. I could also use a link to buy a new one since install looks easy. I would rather buy a new one than bake the old one.
2. With radio off there is a buzzing sound, like a lose speaker wire - again i figured this was the HFL but it does it without being plugged in and with radio off. You can hear the buzz when the car is idling, annone with an idea on where this coming from?
3. Is there any aftermarket radio that will fit it with the boss sound system. I am yet to find out and that might fix #1 and #2 above.

Thanks in advance,

HT
 

·
Registered
Joined
·
27 Posts
Just got the SUV and the outside and inside our near mint. But please take the time to help me with a few issues if you can.
1. The HFL doe snot work - i disconnected it because i thought it was draining the battery. I could also use a link to buy a new one since install looks easy. I would rather buy a new one than bake the old one.
2. With radio off there is a buzzing sound, like a lose speaker wire - again i figured this was the HFL but it does it without being plugged in and with radio off. You can hear the buzz when the car is idling, annone with an idea on where this coming from?
3. Is there any aftermarket radio that will fit it with the boss sound system. I am yet to find out and that might fix #1 and #2 above.

Thanks in advance,

HT
Not sure on the buzzing, maybe a loose negative wire somewhere introducing the buzzing. As far as the HFL goes, I tried the baking method numerous times on my 05. It worked the first time and last a few months before going out again, never could get it to work again. I thought about buying a new one, but was expensive. I think about $250 - $300 depending on the online retailer. I ended up going aftermarket Kenwood head unit with bluetooth. See this Facebook post. My set up is the first comment.

You didn't mention if you have Nav or not. I don't but do(did) have rear entertainment. Going aftermarket I lost RES, but no big deal for me. I have read it is possible if you have Nav, just never looked into it, since didn't apply to me. With aftermarket you can get XM, backup cam, bluetooth audio as well as calls. Good luck in what ever you decide to do.

Sent from my SM-G973U using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Not sure on the buzzing, maybe a loose negative wire somewhere introducing the buzzing. As far as the HFL goes, I tried the baking method numerous times on my 05. It worked the first time and last a few months before going out again, never could get it to work again. I thought about buying a new one, but was expensive. I think about $250 - $300 depending on the online retailer. I ended up going aftermarket Kenwood head unit with bluetooth. See this Facebook post. My set up is the first comment.

You didn't mention if you have Nav or not. I don't but do(did) have rear entertainment. Going aftermarket I lost RES, but no big deal for me. I have read it is possible if you have Nav, just never looked into it, since didn't apply to me. With aftermarket you can get XM, backup cam, bluetooth audio as well as calls. Good luck in what ever you decide to do.

Sent from my SM-G973U using Tapatalk
Thanks for taking the time. Yes i have navigation with Bose. I will look again on your facebook to see if i can find a new radio - seems like that would fix all my issues.
 

·
Registered
Joined
·
580 Posts
I replaced the HFL and as mentioned it was about $250 online.

In case it helps, we had buzzing/cracking coming through the speakers and it ended up being the dealer installed iPod connector where the wiring was T’d into the back of the head unit. It was a USA Spec model and I just replaced it with the same. The new unit came with the old style 30 pin connector and with RCA jacks to hook up whatever kind of plug you would need.

As mentioned, check grounds - I would add at the head unit and amp. As stereo shop might be able to help.

There are posts here where guys have installed Sony and Pioneer units as well. The nav and Bose might complicate things. Sounds like crutchfield can make some special wires.

Good luck!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I replaced the HFL and as mentioned it was about $250 online.

In case it helps, we had buzzing/cracking coming through the speakers and it ended up being the dealer installed iPod connector where the wiring was T’d into the back of the head unit. It was a USA Spec model and I just replaced it with the same. The new unit came with the old style 30 pin connector and with RCA jacks to hook up whatever kind of plug you would need.

As mentioned, check grounds - I would add at the head unit and amp. As stereo shop might be able to help.

There are posts here where guys have installed Sony and Pioneer units as well. The nav and Bose might complicate things. Sounds like crutchfield can make some special wires.

Good luck!
Thanks for taking the time to respond. Sounds like the static issue i am having.The SUV is amazing shape but the AC is controlled by the touchscreen which i am reading is problematic when replacing the radio.
 
1 - 5 of 5 Posts
Top