Acura MDX SUV Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hey everyone, I've had a problem with my NAV system - when I start the engine the NAV intro screen turns on, though it doesn't always load the system so that I can use it. The intro screen will often just reset over and over, or the screen will just go black. I can't use any of the functions in the system, including the AC functions when this problem occurs. I've found that this problem doesn't always happen - maybe about 80% of the time. All other times it works fine. It's very frustrating and I feel like if I take to the dealer I'll be taken advantage of. Does anyone know how to fix this problem?

I thought maybe it was the NAV DVD, so I pulled it out of the DVD drive under the passenger seat and while there are no scratches on the DVD, there is a cloudy ring around the outside of the DVD. Could this possibly be causing the problem and I just need to clean the DVD? I don't necessarily want to buy another NAV DVD or damage the one I have when the problem could easily be another completely different thing. Help!

Thanks a lot! I greatly appreciate any feedback.

I attached a picture of the NAV screen when it starts up.


Sam
 

Attachments

·
Registered
Joined
·
286 Posts
Oh man. This brings back memories from earlier this month. My unit had this and it turned out it was the unit. Happened 95% of the time. Had to send it back to Alpine USA to get repaired. Acura Canada quoted me $6400.00 Cdn to replace. Yeah right. Alpine USA repaired for $458.00 Cdn. Plus tax and shipping
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
whoa! whew, thanks a lot! $458 is a relief. that last number is much less than the first number you said, hahaha. So, is it the DVD player? Do I just contact Alpine USA and say that I have a faulty DVD player?
 

·
Registered
Joined
·
286 Posts
That $458.00 is Canadian so the US equivalent is less. The DVD navi drive is under your passenger seat. 5 cables removed and two brackets and it is out.
In Canada we cant send to Alpine USA directly so we had to go through Canadian vendor who is a partner with Alpine. If you are in USA you can call them directly. They will get you to send unit to California. You will need to include original navi DVD.

You may wish to rule out DVD as issue though. In my case i bought 2014 version directly from acura. 179.99 + 32.00 shipping. Ouch. and it made no difference. Not to mention tons of people have had this problem and sending to Alpine resolved. That is better than scouring scrapyards to find the exact unit and even then it may not work and you wont have the code. Further, Alpine provides 90 day warranty with repair
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
ok! so, it sounds like calling Alpine is the move! thank you so much for this! saving me a lot of time and money.
 
1 - 5 of 5 Posts
Top