Acura MDX SUV Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hey guys,

Need help before I throw parts at this problem. Wife drove car home and parked it. This morning it cranked no start. I completed the following:

checked fuses- all good
battery- good
Sprayed brake clean into intake- no start
check timing belt- removed rear cover all good.
Noticed immobilizer light (green key) is flashing - I couldn't find another key after tearing the house apart. Called lock smith to reprogram/sell me a new key. - 160 bucks later and nothing. He stated its either the immobilizer unit in the steering column or the ECU. but he was able to program keys into the ECU. But light continues to flash.

two questions:
where is this ECU located in the car?
Can I buy the ECU and immobilizer unit off the same car, and plug and play? Do I have to call locksmith to reprogram the car again.

Thanks for the help

Glenn
 

·
Registered
Joined
·
1,681 Posts
The PCM is part of the immobilizer system, but it's a total crapshoot to assume it's bad.

FYI, it looks like there are two fuses associated with the immobilizer - #6 (15A) in the driver's under-dash box, and #92 (7.5A) in the "auxiliary" fusebox.

You really need to plug into an HDS (Honda Diagnostic System) computer and see what it tells you. It's an awfully complicated system to try to figure it out by swapping out (expensive) parts. HDS clones aren't all that expensive, though getting one installed and working can be a little fiddly.
 

·
Registered
Joined
·
432 Posts
I am surprised that the locksmith programmed the keys to the car, usually they just clone the existing key.
Anyway, are your seat presets still set and does the driver's window auto up function work as normal?
Sometimes these issues that look like immobilizer can actually be linked to loose or corroded battery terminals, or even the main ground wire.

There were some reports of no start conditions, a technical service bulletin (TSB) went out over 10 years ago saying to remove all keys except the ignition key and even a special way to put the key in:
Engine Cranks but Doesn't Start; Immobilizer Light Blinks
Getting complaints from owners of 03-04 MDX of the engine cranking but not starting and immobilizer system indicator blinking? The problem could simply be rooted in how our client turns the ignition key.
For quick starting, advise your clients that when inserting the key into the ignition switch, don't push in against the spring, and when turning the switch, don't do it rapidly This lets the immobilizer receiver read the ignition key's transponder ID code without interruptions.


Its free and worth a shot, otherwise the HDS or a trip to the dealer :/
 

·
Registered
Joined
·
3 Posts
My 04 x is doing the same thing. 111k miles and died driving like 30 mph and hasn't started since. New starter new battery checked fuses and swapped relays everything looks good. Everything but the valve cover is grounded on the motor could that be my issue. All I have is a test light but I'm not getting spark someone please help I'm going on 3 weeks fighting this car.
 
1 - 5 of 5 Posts
Top