Acura MDX SUV Forums banner

1 - 20 of 72 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
2002 MDX with 278,XXX.

My son has the vehicle at school. Last week VTM and CE light went off and it runs poorly, very sluggish. Since he is away, my usual shop cant look at it. Codes pulled indicate EGR and misfire. Shop replaced plugs, no luck, still misfires under load, replaced EGR valve, same deal.

Coils replaced in 2013, Valve adjustment and carbon cleaned from manifold passageway done August 2016.

Any thoughts?

Thanks!
 

·
Registered
Joined
·
53 Posts
Discussion Starter #3
Timing belt was done at 105,000 and 210,000 along with the other scheduled 105,000 and 210,000 stuff
 

·
Registered
Joined
·
53 Posts
Discussion Starter #5
Hopefully they can track it down. Was running great then this came on all of a sudden Friday as my son was driving it. Been a great vehicle so far. Bought it 10 years ago with 43000 miles. Replaced tranny at 273000. Little things here and there but nothing major (motor mounts, coils, etc)
 

·
Registered
Joined
·
1,739 Posts
I would have bet on a jumped timing belt as well, but it could have been something local to one head or the other. It might shed a clue to see any codes it's throwing.
 

·
Registered
Joined
·
172 Posts
Pulled my v6 accord apart, timing had jumped, however, new belt, timing corrected, still missing, I'm leaning on valve adjustment needed for me. I hope someone knew how to do valve adjustment on yours, I've seen them done wrong b4.

Sent from my XT1585 using Tapatalk
 

·
Registered
Joined
·
53 Posts
Discussion Starter #8
They were going to check the valves today. When I had them adjusted this summer, they were a lot noisier than before. I will post an update when they get back to me.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #9
Valves were out of wack, still misfiring, looking for a bad injector...any other thoughts?

Valves were adjusted earlier this year, after they did it, they were much noiser than before....
 

·
Registered
Joined
·
172 Posts
Have u checked the timing belt via the access holes in the timing covers? Easy to check...

Sent from my XT1585 using Tapatalk
 

·
Registered
Joined
·
172 Posts
Clogged injector or miss should show on stft on the respective bank. Pull off coils one at a time and see which one is missing then start working from there.

Sent from my XT1585 using Tapatalk
 

·
Registered
Joined
·
1,179 Posts
Stuck open EGR valve could cause multiple cylinder misfire. Idle would be affected also.

good luck
 

·
Registered
Joined
·
53 Posts
Discussion Starter #14
Well, its done. My son is picking it up tonight.

Not sure what caused all of this to begin with.

Pulled plugs when they first got it, very fouled, ran the car and fouled the new set of plugs.

Valves needed adjusted, 2 ignition coils were bad, EGR valve was also bad.

So $1150 later she seems good to go....according to them. They drove it a bit yesterday and it ran well.


I hope to get a few more miles out of the MDX. My other son turns 16 in December. I want to give him this one and keep it local. Then give my son in college my 2009 MDX and I am looking for a 2015-2015 Advance for me.

Fingers crossed!
 

·
Registered
Joined
·
53 Posts
Discussion Starter #15
It was too good true. My son called this morning and said after a few miles driving it today the CE light came on and engine started shaking again. Wont run well over 45-50mph. Exact same issues I just flushed $1200 down the toilet to repair.

Shop took it for a test drive last week and said it was fixed.

Any thoughts?

Advice on how to handle the shop? Its not my usual shop since my son has the car out of town.

Thanks
 

·
Registered
Joined
·
1,179 Posts
Fouled plugs could be rich mixture (Fuel delivery, poor AF sensor/s) or oil consumption (leaky rings or valve stem seals). Something caused those plugs to foul/miss.

EGR misfire is a excess lean mixture and should not cause fouling.

Suggest confirming plugs are fouling and get to the bottom of fouling.

good luck
 

·
Registered
Joined
·
172 Posts
Failing o2 sensor causing engine to pour in extra gas? If plugs black, it's rich. If plugs white/ light grey, it's lean...

Sent from my XT1585 using Tapatalk
 

·
Registered
Joined
·
1,179 Posts
Are EGR codes still present? What code? Just replacing EGR valve may not solve P0401 EGR code.

See following example of cleaning EGR passages for Acura TL (same engine).


good luck
 
1 - 20 of 72 Posts
Top