Acura MDX SUV Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
HELP! I purchased an 07' MDX 6 months ago and have had various weird issues since. First issue I had was the "check charging system" light randomly comes on and immediately turns off. I disconnected the blue tooth because I was told that that commonly causes that issue. Issue continued. Car will randomly die while sitting, no lights left on or anything that would cause the battery to drain. It will then start up after a few minutes. battery and alternator check out fine. Dealership thought it was an issue with the a/c regulator getting stuck and causing a drain. Replaced that, issue still occurs.
The most troubling issue began about 6wks ago, I will be driving and the car is acting completely normal until I stop at a red light or stop sign. When I try to accelerate again the car acts as if it is in neutral, revs but does not move. If I put it in park or neutral and back into drive it will then go. This also occurs with the navi resetting itself repeatedly at the same time. It's not throwing any codes, no dash warnings, the car drives perfectly in sport shift mode, no sign of any tranny issues whatsoever. Totally weird. Anyone experience this or know what could be causing this?
 

·
Registered
Joined
·
3,339 Posts
Check your ground cable!
 

·
Registered
Joined
·
24 Posts
Bump because I wanna know how this turns out, I have the same model year and there's the slightest hesitation in shifting right now!
 

·
Registered
Joined
·
1,118 Posts
sounds like you have a loose power cable. Check the power cable from the battery to the alternator and to the fusebox.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Took it into the dealership, they could not replicate the issue. Didn't find anything wrong. Connections and wiring all looked good. Grounds were good.

Issue persists.

Today I took it in to another mechanic, he couldn't replicate either. He Said everything checked out and looked fine.

A/c also pauses when it's about to happen, sometimes the radio pauses momentarily, sometimes the Navi turns on or off or the doors lock/ unlock. Sometimes the VSA turns off and I get a warning. This happens right before the car shifts itself into neutral but is still in drive. It only happens while idling. Definitely electrical in nature but figuring out what's causing it? Idk how, especially since it doesn't happen everyday.

Any other suggestions or input would be greatly appreciated!
 
1 - 6 of 6 Posts
Top