Acura MDX SUV Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
130,000 mile mdx lifetime owner... Leaving a traffic light under light to average acceleration, something gave or broke\, I believe in the drivetrain. I was thinking motor mount, but site suggests to "power brake" car and look for excessive movement, in forward and reverse, no notable lift or noises...?? I did notice as I accelerate more the car , does not put power to the motor..?? I never powered braked my mdx before , so this may be a safety, governor??( for lack of other words).
Also took around the block, brakes work good, acceleration is good , no vibration while driving or stopped, no liquids leaking, belt is still there and in good shape..
No noticeable noises, rattles, or weird stuff going on... Looking for mdx gurus, advice AGAIN...
 

·
Registered
Joined
·
3,389 Posts
Have you tried checking your suspension? sway links? springs?
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #4 ·
Ill take to mechanic tomorrow, cant get underneath.
****Update ,chassie and front end checkout ok,of course I have torn cv boots$, and cracked compliance bushings$$ but not severe enough to cause any noises or play.
***So I filled up on gas local Phillips 66 yesterday, could this have been an engine miss-fire?? from gas?
 

·
Registered
Joined
·
1,179 Posts
Cracked compliance bushings are expected on vehicle of this vintage. Unless movement is possible, they are not the problem.

I have had 2 CV axle replacements on my 03 MDX. Used Autozone new axles. OK but not great as last replacement was the first AZ axle.

good luck
 
  • Like
Reactions: cookie
1 - 5 of 5 Posts
Top