Acura MDX SUV Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey there guys/gals,I have a 2004 MDX that I have had for a couple years, traded a corvette for it actually and got the better of the deal. I don't use it much at all as I have a truck supplied by my job so it sits , a lot. Anyway I fired it up a couple months back and on came the VTM,ABS and TCS lights and I lost my AWD immediately. I have a code reader but it won't pull the VTM codes, I am guessing I have an ABS sensor bad but without the code I can't pinpoint which one it is or rule it out as the problem. Any help would be great thanks.
 

·
Registered
Joined
·
412 Posts
Jump pin 4 and 9 on the obd2 port and you can get the ABS codes. Like you, I suspect it's one of your wheel speed sensors. Look here - http://www.mdxers.org/forums/18-maintenance/46539-vsa-vtm-4-abs-warning-lights-after-strut-change.html Make SURE you jump pin 4 and 9, or you'll blow the fuse for the ECM. This link ABS | airbag reset | airbag module | airbag light on | engine code | maint reqd | service reset | trouble code | from the post above shows you how to read the ABS codes after jumping the pins.
 

·
Registered
Joined
·
369 Posts
They probably just have dirt or something on them. Also the high end scan tool at Autozone, etc. will read it. Honda HDS will read everycode on the MDX. $180 direct from china. Use only oem if you need to replace one and make sure its seated all the way, which isn't easy.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
It was the Left front sensor , it cleared all codes the second it started, something I hadn't seen before. Usually they need to be driven before they clear but not on this one. Thanks for the responses guys. I just purchased a second 03 MDX for parts that runs perfect but has trans issues.
 
1 - 6 of 6 Posts
Top