Electronics response time - Acura MDX Forum : Acura MDX SUV Forums
LinkBack Thread Tools Rate Thread
post #1 of 8 (permalink) Unread 4 Days Ago Thread Starter
Registered User
 
Join Date: Mar 2015
Posts: 10
Unhappy Electronics response time

Hello everyone,

Since I have purchased my 2014 MDX Elite, I noticed the Navigation/input screen has very slow response times.
If I neede to enter an address, and hit MENU, I would have to wait 30 seconds to a full minute, to get a proper response. Everything else that I enter, is the same result.
Also, sometimes, when I shift from Park to Reverse - the screen is just black. It seems like the backup camera does not kick in. I would have to shift back to Park, wait a few seconds and then shift to reverse...only then it will work. Same goes for shifting from Park to drive. It doesn't happen all the time. However, enough to become a bit frustrating and annoying. Especially, for a vehicle that costs this much.

I know there is not a single vehicle out there without its' gremlins, but in this modern age with our technical advancements and at this price point, surely Honda could have done better.

I have read a few posts in the past about folks having the same issues and they have expressed their frustrations.

Has anyone been fortunate enough getting this fixed? Is Honda/Acura doing anything about it?

I really love my X - no, not that one - my MDX - and I take very good care of her (again, my MDX). She purrs like a kitty - and when she hits 4k RPM - She really meows.

Thanks in advance for your input.

AngelGuard is offline  
Sponsored Links
Advertisement
 
Registered User
 
neoshi's Avatar
 
Join Date: May 2015
Location: Everywhere
Posts: 2,425
Unfortunately, the infotainment in the MDX from 2014-2017 is just pretty damn slow. Way too much crap it's supposed to handle for the CPU it has. That's why in 2018 they actually fixed it by switching to Android based. The backup camera problem did get addressed for 2016 models under TSB 16-048, but it doesn't apply to your 2014. At best, the 2014 has TSB 15-001 which is a slew of bug fixes for the infotainment. However, TSBs are NOT free to do if you are no longer under warranty, so keep that in mind. If you have an extended warranty, you may want to bring up that backup camera issue since it is a safety issue and they may just respond with the latest software update to see if it fixes that.
Attached Files
File Type: pdf B15-001.PDF (764.8 KB, 9 views)
File Type: pdf B16-048.PDF (1.69 MB, 6 views)
neoshi is offline  
Registered User
 
Join Date: Jul 2013
Posts: 2,786
The Nav system on my 2014 USA model isn't quick but it's not as slow as you describe. To determine if yours is really extra slow or just the same as any other 2014 try to do about 3 specific things on the Nav about 2 times each and time them and write down that data then do the same thing on another 2014 using the exact same input and write that down and then compare the two. Make sure you do this at least a few minutes after first turning on the vehicle to give it a chance to be fully ready.

There have been a few software updates (I'm referring to the software - not the maps themselves) for the 2014 Nav, updates of some years ago, make sure you have all the available updates on yours. I don't know what that would be for a Canadian model but someone here might be able to say or a dealer should be able to indicate it.
mdxstang is offline  
 
post #4 of 8 (permalink) Unread 1 Day Ago Thread Starter
Registered User
 
Join Date: Mar 2015
Posts: 10
Thank you, Neoshi.
I still have the extended warranty. I will bring it up with the dealership and hopefully, it gets resolved.
Thanks for the info. I didn't know about the TSB - bug fixes...
Sometimes, when I put it into reverse, the screen goes black. No video. I would have to park or switch it Drive and then back to reverse before it work.
Also, sometimes, out of reverse and into drive, the screen will also go black. No Video. It's annoying as whell.
Thanks for your feedback. It is appreciated.
AngelGuard is offline  
post #5 of 8 (permalink) Unread 21 Hours Ago
Registered User
 
Join Date: Jun 2015
Posts: 358
IIRC the 2015 MDX had a faster CPU and some software changes, which they couldn't/didn't backport to the 2014. It may have been the 2016 but that is not how I remembered it. The backup camera issue sounds really annoying - sorry.
PDXsailor is online now  
post #6 of 8 (permalink) Unread 18 Hours Ago
Registered User
 
Join Date: Jul 2013
Posts: 2,786
^^ You're right in that Acura made some updates/slight software improvements for the 2015 that they didn't offer on the 2014 but I haven't seen anything concrete about a real change to the unit itself - just some conjecture here by people who don't know. I suspect Acura simply didn't feel the need or desire to offer improvements to a model year that was already done - sort of the traditional vehicle sales paradigm - add new functions in the currently selling or new vehicles to attract people to them but don't worry about adding enhancements to vehicles already bought and paid for since it could be viewed as a disincentive for people to buy up to a later model year.
mdxstang is offline  
post #7 of 8 (permalink) Unread 8 Hours Ago Thread Starter
Registered User
 
Join Date: Mar 2015
Posts: 10
MDXSTANG,

Indeed, I don't want to go spend money as it is a disincentive.
Thing is, for a car that costs this much (or for any expensive cars) - to have such a unit is sort of a rip-off from the manufacturers.
With today's technological advancements, they could have simply put an ipad or similar tablet like device and have it programmed with room for improvements.
Understandbly, they all want to make profits in the billions - and we foot the bill. But for heck sake, offer something platable.
Take Apple for example (I personally don't use their products) - they make good products with proper support and consumers ate it all up. Imagine if Honda/Acura did the same.

Sorry, I am just ranting.

Cheers.
AngelGuard is offline  
post #8 of 8 (permalink) Unread 7 Hours Ago
Registered User
 
Join Date: Nov 2016
Posts: 173
I have 17 and it takes little bit longer for NAV to come up after the car goes from reverse to drive .
You would imagine for $50 k car Acura would have put faster CPU in their NAV ..
cardude10 is offline  
Sponsored Links
Advertisement
 
Reply

Related Threads
Thread Thread Starter Forum Replies Last Post
Alpine brings real time traffic data nav to the aftermarket 04mdx4sq Audio & Electronics 2 4 Days Ago 11:47 AM
When is the Best Time To Buy A Car? AutoGuide.com News 0 03-12-2014 12:49 PM
Automatic Daylight Savings Time vincent General Discussions 14 04-05-2005 07:31 PM
For those who can read Chinese... TYP Games & Humor 10 01-23-2005 05:36 AM
Clock (time) without turning on? Steve General Discussions 1 02-06-2002 10:21 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Acura MDX Forum : Acura MDX SUV Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome