2007 Acura MDX Issues - Acura MDX Forum : Acura MDX SUV Forums
Register Home Forums Active Topics Auto Loans Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance
MDXers.org is the premier Acura MDX Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 11-21-2012, 02:53 AM   #1 (permalink)
Registered User
 
AcuraMDX007's Avatar
 
Join Date: Nov 2012
Location: Albuquerque, NM
Posts: 1
2007 Acura MDX Issues

Hey everyone,

So I have had my 2007 Acura MDX tech for almost two years now. I have just now run into a problem. I was driving and my "check engine oil level" light popped up on the dash for a less than half a second and turned off. It has now continued to do this off and on for a couple of weeks. I have checked the oil level and all is ok. I am guessing this is just a sensor issue? Anyone know any information on this or how to fix the problem?

I also noticed today now that it is getting colder outside. I switch my temp from 65 to 77 degrees. When I did this, the car made a noise like something was crunching. I switched back and forth from heat to ac and the car kept making the noise. Is this normal or is does this appear to be a ac compressor going out?

If anyone can help, I would appreciate it! Thanks!
AcuraMDX007 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-21-2012, 07:45 PM   #2 (permalink)
Registered User
 
Join Date: Aug 2011
Posts: 124
First one sounds like a sensor.

Second one is hard to say. Could just as easily be the fan blower motor.
MnMDXDave is offline   Reply With Quote Quick reply to this message
Old 11-22-2012, 10:16 PM   #3 (permalink)
Registered User
 
Needsdecaf's Avatar
 
Join Date: Nov 2007
Location: HTHe Woodlands, TX
Posts: 958
Quote:
Originally Posted by AcuraMDX007 View Post
Hey everyone,

So I have had my 2007 Acura MDX tech for almost two years now. I have just now run into a problem. I was driving and my "check engine oil level" light popped up on the dash for a less than half a second and turned off. It has now continued to do this off and on for a couple of weeks. I have checked the oil level and all is ok. I am guessing this is just a sensor issue? Anyone know any information on this or how to fix the problem?

I also noticed today now that it is getting colder outside. I switch my temp from 65 to 77 degrees. When I did this, the car made a noise like something was crunching. I switched back and forth from heat to ac and the car kept making the noise. Is this normal or is does this appear to be a ac compressor going out?

If anyone can help, I would appreciate it! Thanks!
Second one is your A/C fan clutch.
__________________
2007 MDX Tech Billet Silver / Ebony Bone Stock!
2011 BMW 535i Sophisto Gray / Oyster Stock for now.
Needsdecaf is offline   Reply With Quote Quick reply to this message
Old 11-26-2012, 04:26 PM   #4 (permalink)
Super Senior Member

 
Fabvsix's Avatar
 
Join Date: Aug 2003
Location: NorCal
Posts: 4,957
check oil sensors are FAILING in the 07 MDX's as mine has...they want $250.00 to change it.....I change my oil so I'm living with this failed sensor until and when a TSB is issued so they can change it on a goodwill basis.....
__________________
CURRENT VEHICLES, NOT previous ones!
*****MDX SPORT RULES*****
2004 RL Navi/Blk/Ebony
2007 RDX Tech package/Pearl White/Ebony
2007 MDX Sport/Ent. Black/Ebony

2006 Lucchese Classics Black/Cherry Nile Crocodile belly, upper Black US Buffalo


** Converted to Zaino on 06-12-2002 **
Fabvsix is offline   Reply With Quote Quick reply to this message
Old 11-26-2012, 05:06 PM   #5 (permalink)
Registered User
 
Join Date: Sep 2003
Location: SF Bay Area
Posts: 109
Quote:
Originally Posted by Fabvsix View Post
check oil sensors are FAILING in the 07 MDX's as mine has...they want $250.00 to change it.....I change my oil so I'm living with this failed sensor until and when a TSB is issued so they can change it on a goodwill basis.....
There is a TSB (09-012) for this issue since it is a common problem on the 07 MDXs and some earlier 08 MDXs.
Per the TSB, the switch is easily accessible and easy to change.
__________________
2012 MDX Advance - Palladium/Ebony
2007 MDX Sport - Silver/Ebony (SOLD)
rocketman is offline   Reply With Quote Quick reply to this message
Old 11-26-2012, 05:16 PM   #6 (permalink)
Super Senior Member

 
mesalum's Avatar
 
Join Date: Apr 2001
Location: Northern CA
Posts: 568
I believe this is the appropriate TSB.
Attached Files
File Type: pdf b09-012.pdf (1,023.3 KB, 194 views)
__________________
--
2007 MDX Tech Aberdeen Green/Ebony Delivered 1/30/07 VIN 519189, with new engine at 97K miles
mesalum is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Acura MDX Forum : Acura MDX SUV Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 05:39 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Copyright 2000-2010 MDXers.org. All Rights Reserved.