Check Emmissions and SHAWD lights came on - Acura MDX Forum : Acura MDX SUV Forums
Register Home Forums Active Topics Auto Loans Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance
MDXers.org is the premier Acura MDX Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 03-18-2012, 06:10 PM   #1 (permalink)
Registered User
 
Join Date: Sep 2011
Location: Toronto
Posts: 24
Check Emmissions and SHAWD lights came on

I've read of this problem before but I did notice before it happened that at Idle the truck ran horribly. I had driven about 20 minutes just prior to this all happening. I thought the truck was gonna die on idle so i went to the closest gas station and filled it up from 1/4 tank and put in some fresh 91 octane. I clicked the gas cap more than the 5 times people suggest and started the truck. at first the truck did not want to start it was hesitating on startup then finally caught and continued to run a rough idle. Anyone have any suggestions? again I have the check emmissions light and check SH-AWD light. One note is the truck runs fine when driving.
__________________
2008 Acura MDX Elite
1995 Turbo M3
Blitzkrieg is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-18-2012, 10:25 PM   #2 (permalink)
Registered User
 
Join Date: Dec 2010
Location: Galveston, TX
Posts: 930
First, checkthat your battery charge and voltage are ok. From experience, I know that thesr computer/electronic based vehicles are very sensitiveto low voltage which can occur with a weak battery and starting the vehicle, since the voltage can drop below 10 volts with weak batteries.

That means certain modules may not boot correctly..
You have two somewhat unrelated modules having problems at the same time, which makes it suspicious..

AC

Quote:
Originally Posted by Blitzkrieg View Post
I've read of this problem before but I did notice before it happened that at Idle the truck ran horribly. I had driven about 20 minutes just prior to this all happening. I thought the truck was gonna die on idle so i went to the closest gas station and filled it up from 1/4 tank and put in some fresh 91 octane. I clicked the gas cap more than the 5 times people suggest and started the truck. at first the truck did not want to start it was hesitating on startup then finally caught and continued to run a rough idle. Anyone have any suggestions? again I have the check emmissions light and check SH-AWD light. One note is the truck runs fine when driving.
__________________
2011 Pearl White MDX Advanced
... OEM towing, 20 mm wheel adapters,
... rails/crossbars, wheel well trim,
... side windows acrylic deflectors,
... Michelin Latitude Tour HP 275/45R19
2010 Acura TL Tech.
2001 Mercedes ML 320
2005 Mercedes ML 500 AMG Package
AC_MDX is offline   Reply With Quote Quick reply to this message
Old 03-19-2012, 10:04 AM   #3 (permalink)
Registered User
 
Join Date: Sep 2011
Posts: 105
A weak battery does cause problems and errant check engine lights. However once started it should not run poorly due to bad battery.

You should be able to go into your messages on the navigation and find the Code(s). Post them back here.
andrew_j is offline   Reply With Quote Quick reply to this message
Old 03-19-2012, 08:48 PM   #4 (permalink)
Registered User
 
t-mdx's Avatar
 
Join Date: Jan 2009
Location: USA
Posts: 834
how many miles do you have? are you the first owner?
t-mdx is offline   Reply With Quote Quick reply to this message
Old 03-19-2012, 10:03 PM   #5 (permalink)
Registered User
 
Join Date: Dec 2010
Location: Galveston, TX
Posts: 930
In many vehicles (Mercedes, etc), the modules that fail to initialize correctly will post an error (OBDII) and will not try to reboot again until the engine is restarted.

Bad gas may make the engine miss enough to make the awd be disabled. I remember at least two cases in my old vehicle forums..
__________________
2011 Pearl White MDX Advanced
... OEM towing, 20 mm wheel adapters,
... rails/crossbars, wheel well trim,
... side windows acrylic deflectors,
... Michelin Latitude Tour HP 275/45R19
2010 Acura TL Tech.
2001 Mercedes ML 320
2005 Mercedes ML 500 AMG Package
AC_MDX is offline   Reply With Quote Quick reply to this message
Old 03-23-2012, 06:19 PM   #6 (permalink)
Registered User
 
Join Date: Sep 2011
Location: Toronto
Posts: 24
Hey guys, Just wanted to update you all on what the resolution was.. Sure enough it was the EGR valve had started to stick. so it was failing to close when at idle causing the engine to act erratic. Something to note going forward for anyone having the same issue.
__________________
2008 Acura MDX Elite
1995 Turbo M3
Blitzkrieg is offline   Reply With Quote Quick reply to this message
Old 03-23-2012, 06:37 PM   #7 (permalink)
Registered User
 
Join Date: Feb 2011
Posts: 172
All along owning this vehicle I was worried for the torque converter/transmission like issues ; seems anything can fail on these vehicles....
__________________
08 MDX Tech/Ent
Troy123 is offline   Reply With Quote Quick reply to this message
Old 12-02-2012, 12:16 PM   #8 (permalink)
Registered User
 
Join Date: Oct 2008
Posts: 93
I'm having exact same issues. My MDX is 2007, and battery has been replaced in 2011, so relatively new.

If it is a fault EGR valve, fault, how do we resolve this?

Thanks
Sergio
Sergio is offline   Reply With Quote Quick reply to this message
Old 01-13-2013, 07:23 PM   #9 (permalink)
Registered User
 
Join Date: Oct 2008
Posts: 93
Guys, my wife brought vehicle to Acura $tealer and they hit her with the following:
95$ EGR valve
110$ Diagnositics
110$ install EGR valve
54$ taxes

Total approximate 350$!!!!!!!

BEWARE, and get it done differently.

If the same happens to you, here is what I suggest:

1. Dictate to service rep to change EGR valve at 1/2 hour labour cost.

It should not cost more than 150$.

Take care
Sergio
Sergio is offline   Reply With Quote Quick reply to this message
Old 01-14-2013, 02:26 AM   #10 (permalink)
Registered User
 
Join Date: Jan 2007
Posts: 375
Something does not seem right. EGR is only 95, how can you have a 54 tax? Labor should not increase tax AFAIK.

Quote:
Originally Posted by Sergio View Post
Guys, my wife brought vehicle to Acura $tealer and they hit her with the following:
95$ EGR valve
110$ Diagnositics
110$ install EGR valve
54$ taxes

Total approximate 350$!!!!!!!

BEWARE, and get it done differently.

If the same happens to you, here is what I suggest:

1. Dictate to service rep to change EGR valve at 1/2 hour labour cost.

It should not cost more than 150$.

Take care
Sergio
qqzj is offline   Reply With Quote Quick reply to this message
Old 01-14-2013, 09:32 AM   #11 (permalink)
Registered User
 
Join Date: Apr 2012
Location: Dallas, TX
Posts: 153
Quote:
Originally Posted by qqzj View Post
Something does not seem right. EGR is only 95, how can you have a 54 tax? Labor should not increase tax AFAIK.
Many states do charge sales tax on labor. In Texas the sales tax rate is 6.25-8.25 depending on local city additions. Not all labor is taxable, but some is.

With the spelling difference of labor/labour in the different posts, I wonder if
sergio is in Canada where many taxes are higher? Many dealers also charge a "shop fee" for consumables used (rags, cleaner, etc) during the repair. That is usually a flat percentage of the repair bill and may have been included in the tax?
ls973800 is offline   Reply With Quote Quick reply to this message
Old 01-16-2013, 11:33 AM   #12 (permalink)
Registered User
 
Join Date: May 2012
Posts: 31
Generally with the EGR valve you can just clean out the carbon buildup. I am fortunate to have a friend that only works on Honda/Acura. I was getting the same two codes and since he cleaned it, no problems at all.

I previously had 2 Cadillacs that both had the same issue and cleaning the EGR worked fine. In my experience it is rare that you actually need to replace it.
Why0Why is offline   Reply With Quote Quick reply to this message
Old 02-14-2013, 09:24 PM   #13 (permalink)
Registered User
 
Join Date: Jun 2006
Location: NC
Posts: 4
EGR and clean out cost $400

Leith acura fixed same problem on my 2007 MDX with 80K miles. New EGR valve $150 plus $200 labor to install and clean out tubing and such. Technician said it was caused by the ethanol in the gas. I asked if this was a common problem since all gas now contains ethanol per EPA in NC. He said yes and seeing it more and more. Why do I now feel like I was ripped off?
__________________
Black MDX 01 120K replaced trans at 80K
theorydoc is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Acura MDX Forum : Acura MDX SUV Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:33 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Copyright 2000-2010 MDXers.org. All Rights Reserved.