2004 mdx p0420 emission CEL - Acura MDX Forum : Acura MDX SUV Forums
Register Home Forums Active Topics Auto Loans Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance
MDXers.org is the premier Acura MDX Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 01-20-2013, 07:25 PM   #1 (permalink)
Registered User
 
Join Date: Oct 2012
Location: Central PA
Posts: 43
2004 mdx p0420 emission CEL

Yep another p0420 inquiry.

I have found a lot of good info on this already but want to be as well equipped as I can before I start the repair process.

I bought this used with 116k miles and got a 6 mo. 3rd party warranty that should cover cat converter.

The code came up first late December right before doing the water pump and timing belt job, so I decided to swap plugs and clean the EGR valve while I was wrenching on it.

The light actually stayed off for about 3 weeks and 1,000 miles.

My question is, if it were an o2 sensor it would probably stay on more consistently right?
Also, any good shop should be able to narrow it down to the culprit as apposed to throwing parts at it right?
mjimport is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-21-2013, 01:33 PM   #2 (permalink)
Registered User
 
Join Date: May 2010
Location: Katy, TX
Posts: 594
If you've researched this you know that many things can cause P0420, exhaust leak, faulty primary O2 sensor, faulty secondary o2 sensor, or damaged catalytic converter.

Suggest reviewing ericthecarguy, briansmoble1, and scottykilmer videos on this subject.

The Acura/Honda converters are good, so I would want to first be sure it wasn't something else before replacing.

good luck
__________________
2003 Acura MDX w/ Nav
2006 Acura TSX
1994 Honda Accord
See you down the ROW!
TexasHonda is offline   Reply With Quote Quick reply to this message
Old 01-21-2013, 06:12 PM   #3 (permalink)
Registered User
 
Join Date: Oct 2012
Location: Central PA
Posts: 43
That's where I'm at, I know it's one of those causes but I don't have the scanner so my next step has to be fork over $50 or so for a diagnostic at the shop.
mjimport is offline   Reply With Quote Quick reply to this message
Old 01-22-2013, 11:26 AM   #4 (permalink)
Registered User
 
scorro1's Avatar
 
Join Date: Jan 2008
Location: Nuclear Power Plant, New York
Posts: 143
Autozone or Advanced Auto Parts will run a diagnostic for free.
__________________
2003 MDX Base Silver 142K Miles{
235/65R17 Bridgestone Dueler H/L Alenza,
2004+ Headlights with H9 Bulb Conversion,
Fog Lights equipped with 9012 Bulb Conversion
iPOD Aux hookup to Stock Radio,
Trunk Pet Net}

1991 Acura NSX Silver 31K Miles{
Escort 8500 X50,
K&N Intake
}
scorro1 is offline   Reply With Quote Quick reply to this message
Old 01-22-2013, 06:41 PM   #5 (permalink)
Registered User
 
Join Date: Oct 2012
Location: Central PA
Posts: 43
^ that's how I got the code, but that doesn't show the real time data that will tell if its the cat that's failed.
mjimport is offline   Reply With Quote Quick reply to this message
Old 01-22-2013, 10:20 PM   #6 (permalink)
Registered User
 
Join Date: Jan 2013
Posts: 5
Autozone or Advanced Auto Parts will run a diagnostic for free.
__________________
wiliswene is offline   Reply With Quote Quick reply to this message
Old 02-07-2013, 09:26 PM   #7 (permalink)
Registered User
 
Join Date: Oct 2012
Location: Central PA
Posts: 43
So the CEL has cycled on and off at least 3 times in the last month. The car runs great. Has anyone else had this happen?
mjimport is offline   Reply With Quote Quick reply to this message
Old 02-08-2013, 02:50 AM   #8 (permalink)
Registered User
 
Join Date: Sep 2010
Posts: 11
This just happened on my 04 X. Oreillys let me clear the code a couple of times with their scanner, but it kept coming back on. Car ran fine, but milege was going down. Finally took it to local aamco and paid $100 to hve them hook it to their scanner, then they dropped my exhaust and did a visual on the front and rear precats. Rear cat on backside of motor was bad. $500 for them to replace it. Best price I found on acraoemparts.com was $320.
I did some research and decided to try the spark plug antifouler trick, as I was due for emissions and needed that cel off. The antifoulers remove the o2 sensor from the exhaust stream (but the o2 sensor must work...)
Worked like a charm! Been amonth now, no cel. But I still have a bad cat and gas mileage, so its definitely a temporary fix.
Don't know if your cats bad, but it was worth it to find for sure before I started tearijg the car apart!
Good luck
t-bone is offline   Reply With Quote Quick reply to this message
Old 02-08-2013, 02:56 AM   #9 (permalink)
Registered User
 
Join Date: Sep 2010
Posts: 11
Sorry for typos, on a tablet... just wanted to add that the scanners at auto part stores can only pull the generic code. My oreillys recommended the aamco cause they knew they had the real scanner, which is several thousand dollars. But is much more specific.
t-bone is offline   Reply With Quote Quick reply to this message
Old 02-08-2013, 01:20 PM   #10 (permalink)
Registered User
 
Join Date: Oct 2007
Location: DC
Posts: 137
Thanks for sharing. Good info.

Quick question, how do you know the rear cat is bad? From the visual inspection?
proman is offline   Reply With Quote Quick reply to this message
Old 02-09-2013, 08:14 AM   #11 (permalink)
Registered User
 
Join Date: Oct 2012
Location: Central PA
Posts: 43
Good info, I don't think the mileage has degraded yet, but its my wife's car so I'm sure she wouldn't notice either way.

I guess I'll just keep on trucking and check the cel code every now and then to see if its still the same fault.
mjimport is offline   Reply With Quote Quick reply to this message
Old 02-10-2013, 03:12 PM   #12 (permalink)
Registered User
 
Join Date: Sep 2010
Posts: 11
I gotta tell ya, when I dropped the "jpipe", I could look up into the BOTTOM of both cats, but they both looked the same to me... But by doing the antifouler trick to only the rear cat, the cel went off and has stayed off, telling me he was right. But ihave no idea what the tech looked at different than me.
Maybe from the top, but I doubt he took the cat off. But could have looked down the a/f sensor hole... That's probably where he looked. It is at the top of the cat.
t-bone is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Acura MDX Forum : Acura MDX SUV Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 06:23 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Copyright 2000-2010 MDXers.org. All Rights Reserved.