electrical system tured off while driving - Acura MDX Forum : Acura MDX SUV Forums
Register Home Forums Active Topics Auto Loans Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance
MDXers.org is the premier Acura MDX Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 11-30-2012, 05:17 PM   #1 (permalink)
Registered User
 
mymdxsuv's Avatar
 
Join Date: Nov 2011
Location: GTA
Posts: 16
electrical system tured off while driving

Hi friends, I have 2007 Acura MDX. What happened today, when I was driving my MDX at 50-60 km/h in early morning? My MDX HID lights start blinking and I heard a "click" noise in driving cabin. Sudden I saw all dashboard lights turned off. engine stopped. After 5-10 seconds all system came back to normal. It was never happened before. Help me!fficeffice" />>>
>>
>>
>>
>>
mymdxsuv is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-30-2012, 10:35 PM   #2 (permalink)
Registered User
 
mymdxsuv's Avatar
 
Join Date: Nov 2011
Location: GTA
Posts: 16
no reply
mymdxsuv is offline   Reply With Quote Quick reply to this message
Old 12-01-2012, 08:53 PM   #3 (permalink)
Registered User
 
Join Date: Jul 2010
Posts: 101
Quote:
Originally Posted by mymdxsuv View Post
Hi friends, I have 2007 Acura MDX. What happened today, when I was driving my MDX at 50-60 km/h in early morning? My MDX HID lights start blinking and I heard a "click" noise in driving cabin. Sudden I saw all dashboard lights turned off. engine stopped. After 5-10 seconds all system came back to normal. It was never happened before. Help me!fficeffice" />>
>
>
>
>
Check there
1. Bad alternator (intermittent)
2. Battery terminal becomes loose
3. Short wires of some sort

Good luck!
MDXIMUM is offline   Reply With Quote Quick reply to this message
Old 12-01-2012, 09:55 PM   #4 (permalink)
Registered User
 
Join Date: Jul 2012
Posts: 114
The clicking noise suggests a relay of some sort. If it happens again, try switching keys. For some reason, my first thought is a problem with the antitheft/immobilizer or something in the ignition switch.
kokerj is offline   Reply With Quote Quick reply to this message
Old 12-01-2012, 10:28 PM   #5 (permalink)
Registered User
 
mymdxsuv's Avatar
 
Join Date: Nov 2011
Location: GTA
Posts: 16
Ok friends, i'll check all. And let u know

Thx
mymdxsuv is offline   Reply With Quote Quick reply to this message
Old 12-05-2012, 07:40 AM   #6 (permalink)
Registered User
 
mymdxsuv's Avatar
 
Join Date: Nov 2011
Location: GTA
Posts: 16
hi, i checked battery terminals. they are in good condition. one more thing. some times when i turned my SUV key in engine off position. all electrical system turned off. then, I’ve to put NAVI and RADIO unlock codes to make them operational. for this issue, i think its ignition switch problem.

thx
mymdxsuv is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Acura MDX Forum : Acura MDX SUV Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question

Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:30 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Copyright 2000-2010 MDXers.org. All Rights Reserved.